Ford Powerstroke Diesel Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
okay so i bought some xenon lights from xenonpros but i cannot figure out where to plug them in! :dunno: the ballast does not plug into the stock wiring connector thing

and i got a relay harness for each ballast that has 2 male connecter thingys commin out of it and each harness plugs dirctly into the ballast connecter...so i end up with everything pluged in except for 2 little male metal things

im very confused, any help would be great...

thanks
 

·
Registered
Joined
·
60 Posts
THE PLUG THATS GOS TO YOUR HEAD LAMP SHOULD PLUG INTO THE BALLAST BOX. IF NOW YOU COULD OF GOT THE WRONG KIT. SOME PICS WOULD HELP TO
 

·
Registered
Joined
·
1,727 Posts
they should have sent an adaptor for your stock plug, and then the only thing left unhooked would be a high beam wire, which is optional.
 

·
Registered
Joined
·
60 Posts
WHAT TEMP HID DID YOU GET I GOT THE 8,000 AND IT LOOKS LIKE A VETTES HAEDLAMPS SUPERBRIGHT I LOVE MINE I WILL NEVER GO BACK TO STOCK
\\
 

·
Registered
Joined
·
1,727 Posts
I'm running 4300s, it's the same temp the bmw and benz.......come with. Supposedly it's the highest color temp you can legally run.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 · (Edited)
i got 6000, and heres the pics of the setup i got
im gonna try and make this as detailed as possible

here is the ballast pluged into the xenon bulb, notice the plug on the other end


here is a pic of the inside of the plug on the ballast


okay now here is a pic of the plug on the harness that goes into my stock headlight


obviously those 2 do not match up ^^^^

okay heres where it gets tricky
this is the relay harness, i have circled the 2 male prongs and the the 2 connectors that go to the battery, i have also circled the plug on the relay that fits perfectly into the plug on the ballast...the white sploch is just a fuse box i accidentally circled


now here is a pic of what happens when i plug the ballast to the relay, i have circled where they connect


and after connecting the ballast and relay, all i have left free to elswhere connect are these two male prongs on the relay


now im guessing once i figure out where to plug these two prongs, my headlights will then work...i hope my description was clear
 

·
Registered
Joined
·
792 Posts
I am super glad that you have a McCulloch kit. I have just had to completely replace the kit in my truck after a wire went out.

Obviously the red wire goes to the battery and the black wire goes to a ground on your truck.

The two male prongs, with black and white wires plug into the black connector in your second pic. On my truck those two black and white wires plugged into the factory wire that goes to the stock bulbs that tells them when to turn on. Afterall I do have a Nissan Titan. I hope this helps you out, if not, you may have gotten the wrong kit. Do you know what size # kit you got?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #11 ·
with black and white wires plug into the black connector in your second pic. On my truck those two black and white wires plugged into the factory wire that goes to the stock bulbs that tells them when to turn on. Afterall I do have a Nissan Titan. I hope this helps you out, if not, you may have gotten the wrong kit. Do you know what size # kit you got?
the black and white prongs cant plug into the 2nd pic one cuz that has 2 male prongs coming out of it also, i guess it does kinda look like its a female
 

·
Registered
Joined
·
792 Posts
the black and white prongs cant plug into the 2nd pic one cuz that has 2 male prongs coming out of it also, i guess it does kinda look like its a female
The black and white male prongs plug "through" the black connector to plug into your factory harness. Sorry for the confusion.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #13 ·
that still doesnt make much sense...someone told me to plug the white and black male prongs into the hi-low beam box, but i dunno where that is
 

·
Registered
Joined
·
750 Posts
What kit number does the label that came on the package say it is? Go back and look on their website and make sure that is the right kit listed for your truck. Do that before you start hacking into the wiring.
 

·
Registered
Joined
·
792 Posts
I'm sorry man. I wish I could help you out, but I only know about the 9006 kit man. Once again I apologize and sorry if I confused you.
 

·
Registered
Joined
·
792 Posts
ahh its cool, im just gonna take it somewhere ha
I had a guy install my kit for me the first time. And then when I had problems with it, bad connector, I had to take apart the entire thing and put it back together myself. It was worth it though. Because now I know how to do it, as long as it's 9006 :hehe:
 
1 - 18 of 18 Posts
Top