Ford Powerstroke Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
125 Posts
Discussion Starter #1
Took truck to dealer this morning for wrench light and reduced engine power. Truck would go into limp mode after driving for 15 min. Started when shooting up 6% grade going camping this weekend.

Dealer just informed me it needs a new oil cooler and t-stat. This requires cab off repair right? I knew 6.0's had oil cooler problems but thought ours were better. Truck has 66,000 miles on it and never had any problems. Any ideas why this failed prematurely? Truck has had 3 radiators. Not sure if they replaced coolant or reused it. Or do you think t-stat failed? Limped truck home 150 miles. Would pull over and shut truck down. Coolant full and oil was full so I drove it home.

Anything you guys recommend doing while truck is in shop? I told them to change oil again, replace coolant, and replace radiator hoses with updated double o-ring. Let me know if they should do anything else

Appreciate any feedback you guys have. I am glad I had the 11B23 update. Without it, I would have never known there was a problem and drive it until cooler busted and lifted head gaskets. You guys with tuners can see your temps unlike us that are still stick. I am fortunate u still have a warranty. Now I want a tuner to view temps. Hopefully I didn't do any damage limping truck home.
 

·
Registered
Joined
·
1,621 Posts
im assuming you have a 6.4? what year is it....
 

·
Registered
Joined
·
125 Posts
Discussion Starter #3
Yes 6.4. It's an 08 Job 1
 

·
Registered
Joined
·
125 Posts
Discussion Starter #4
Hope cooler doesn't fail again 65,000 miles later. Cost is $2800
 

·
Registered
Joined
·
125 Posts
Discussion Starter #5
Anyone have any input on why my oil cooler may have failed? Truck is a Job !. Not sure if Ford did an upgrade on oil cooler since mine 5 years ago. Swung by dealer today and they didnt remove the entire cab. They had it tilted. Hope to get some feedback from you guys.

Thanks
 

·
Registered
Joined
·
4,609 Posts
It could have been because it got clogged with crap from the cooling system and failed. You should look into CAT coolant and a coolant filter. THat should keep it from failing again.
 
1 - 6 of 6 Posts
Top