Ford Powerstroke Diesel Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
94 Posts
Discussion Starter #1
Went to start my 7.3 today and it turned over slow, and wouldn't start. Like it would with dead battery's. So I tossed a charger on it and came back later. Now I turn the key and nothing happens... Tried putting the tranny into Neutral, no joy, back to Park, no joy.. Where should I go from here?
 

·
Premium Member
Joined
·
18,040 Posts
Have you got a wts light when the key is turned on?
Could have batts that won't hold a charge. Take them both out and have them tested.one or both may be bad, and causing the other one not to charge.

Sent from my Acer Android Tablet
 

·
Registered
Joined
·
94 Posts
Discussion Starter #3
Both Batts are good.. Swapped starter relay (307) around, still no joy.
 

·
Premium Member
Joined
·
18,040 Posts
Are you getting a wts light? You had both batteries checked? Out of the truck and independantly? I have seen batteries that look like they are good, read 13.xx volts, and then when load is applied they go down to 3 or 4 volts.

Sent from my Acer Android Tablet
 

·
Registered
Joined
·
94 Posts
Discussion Starter #5
The WTS light does come on. Batteries r new.
 

·
Premium Member
Joined
·
18,040 Posts
Sounds like the starter is bad.

Sent from my Acer Android Tablet
 

·
Registered
Joined
·
94 Posts
Discussion Starter #7
Thats what I was afraid of... I have about 4" of standing H2O under my truck from the rain we had today. Going to have to pull it off of my rock driveway onto the paved drive so I can work on it.
 

·
Registered
Joined
·
94 Posts
Discussion Starter #9
Turned out the brushes in the starter were AWOL. All better now :)
 
1 - 9 of 9 Posts
Top