Ford Powerstroke Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have an '02 f-250 with 7.3 and a 5 speed. When I start the truck to warm up it won't go into the high idle mode. I have replaced the clutch interlock switch or neutral safety switch (whatever it's called) and now cruise control works so I know that's good. Also the brake turns cruise off so that switch is good too. Any other ideas?
 

·
Registered
Joined
·
12 Posts
the parking brake also has to be on. if the brake light in the dash is not on even with the parking brake set it will not idle up. i have to wiggle the button that turns on the light sometimes to get my light to come on. letting the pedal slam up when you release it is hard on it and will cause that button to go bad
 

·
Registered
Joined
·
99 Posts
I didn't know that the ebrake had to be on. My parking brake has never been on and the light didn't work but it idles up to about 900-1000. Should it go higher than that?


Sent from my iPhone using Autoguide
 

·
Registered
Joined
·
6,107 Posts
it has to be in park for it to go into high idle.
 

·
Banned
Joined
·
5,630 Posts
I have an '02 f-250 with 7.3 and a 5 speed. When I start the truck to warm up it won't go into the high idle mode. I have replaced the clutch interlock switch or neutral safety switch (whatever it's called) and now cruise control works so I know that's good. Also the brake turns cruise off so that switch is good too. Any other ideas?
It has to be cooler than something like 40*, the parking brake has to be on, and you have to be sitting still w/out touchign the pedals for something like 7 minutes or 10 minutes. the high idle isn't nearly as high as a high-idle chip would say.
 
1 - 7 of 7 Posts
Top