Ford Powerstroke Diesel Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Last night I hooked up the new Recon Big Rig Ice running board lights. They work great, shine bright and hopefully keep the twerps that ride next to me and don't want to let me over out of my way.

However, now that I have been in the truck driving around I am starting to find all the problems that I have made for myself. None of the windows will work, the dome light will work but the other lights within will not work, and the clock will come on but the radio does not work. I have replaced the 30A maxi fuse under the dash with no luck. I bought a multimeter and have found power still going to the driver side window controls so I'm headed to the junkyard in search for one hoping that the solution to the lack of fresh air while driving down the road.

During hookup I spliced into each front turn signal during hookup. Might have cut one too many wires and had to reconnect a wire on the wiring harness back together. I also ran the courtesy wire into the cab and spliced in the black/light blue wire that goes to the dome light under both step panels.

Has anyone had to trouble shoot something like this? I know electrical trouble is like lighting, it never strikes the same place twice. If anyone has any input, that's a step forward for me.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
That idea has been on my mind. Too bad the weekend is over and the work week is staring at me down the sights. Thankfully the truck drives.
 
1 - 3 of 3 Posts
Top