Ford Powerstroke Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Alright I'm new to posting threads, so bare with me. OK to start off I have a '96 F250 Powerstroke. I blew the engine in it so i took the engine out of my dads wrecked '92 F250 7.3L IDI and placed it in the '96. The trans from the '96 is still in the truck and is hooked up to the 7.3 IDI. Also before I leave this out the IDI has sat for over 3 and a half years till now. It runs with minor problems. but the only major problem is that the truck wont get over 45 mph, even when throttle is to the floor. its not giving full rev throu the gears either it only gets full rev when in Park or Neutral. What could the problem be? the Transmission or the Engine.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #2
If anyone has a hint please say someting. I just would like to hear other people opinions. Anything to get the gears a turning in my head.
 

·
Registered
Joined
·
19 Posts
Your cross breeding two different anamals here. The older IDI probably dosen't have half the sensors that the transmission is looking for. If I remember correctly the powerstroke has a drive by wire throttle system, correct? so trans may be looking for the electric throttle pedal signal and it's not there anymore. Things like that are what your looking for. Yes the engines are the same size and will physically swap/drop into place. But that dosen't mean it will work or that it's the best idea. although it can be done. The trans is electronicaly controlled so it needs input from all the sensors to work correctly. what trans did the idi have behind it? Why not use that trans, wiring harness, fuel system,dash, linkages, ect. Prob would've been easier to fix the 92 truck with parts from your blown up powerstroke truck. maybe? Food for thought. Im shure you had to do allot of cutting and splicing and modifying to get the idi running in the powerstrokes place.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
Ok. I found my main problem. I had the Injection pump advance in Timing. Now the truck runs up to 60mph but it still dosnt shift at the correct rpm or down shift when in OD to speed up. I have to manually swich OD off to downshift to 3. The Trans in the 92 is the same trans in the 96. (E4OD) sak778. thanks for the reply. the powerstoke did run by fly by wire. (Electronic) and I asked a man I know at the towns Napa store, he used to work at the towns Ford dealership and worked on my Dads truck as well as mine, so he knows thim inside and out. He told me i need to try and get the rpm sensor hooked up in order to let the trans know what rpms to shift at. also i havent cut any wires. but i got one hot wire to the injection pump to the fuel shut off solenoid to turn the engine on and off by the key. other than that. the truck runs A LOT better now. just as long as i get to 60 im ok. but getting it to shift right would be good.
 

·
Registered
Joined
·
19 Posts
I recently bought a 92 with an auto. it shifted a little funny. would not down shift to passing gear, converter would not lock up, and od off switch would not do or control anything. but it up shifted fine had od and reverse I could drive around town, up shifed at stop lites ect. It only took 1200 miles to wipe out everything inside. the wiring to the trans control computer had half a dozen wires chewed in half from sitting and being nested in.

Long story short I had to replace the under hood harness fuse box and all the way from the blower motor around the radiator and down to the transmission. you could do the same and use the comp, speed sensor, mpl, ect out of the 92.
I got parts from a 93 to repair my 92 and still ran into a couple differences in plugs. still waiting on the trans to be installed to see if it will even work out

Problem with that is the valve bodies have different shaped plugs so you would have to have a trans shop swap the vave body/ solinoid pack. aka dumbdown the trans.

So basicly swap all the harnesses under the hood and anything that it plugs into valve body, computer, ect... and turn the whole drivtrain into the 92. And hope the harness plugs into the firewall cab harness, Or you'll be swapping the dashes also. but i'm pretty shur you'll be ok there.

YMMV

Hows that for food for thought.....
 
1 - 5 of 5 Posts
Top