Ford Powerstroke Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
178 Posts
Discussion Starter #1
So when I step on the brakes it kind of pulses. No noise or anything, not ABS (but feels like a minor version of ABS). No lights, no codes. No pull left or right. Just feels like the brakes are gripping, releasing, gripping, etc. Pulled the wheels and calipers off. Pads are fine, rotors seem perfectly smooth, no play or slop anywhere.:dunno: The only thing I can think is a warped rotor, so I'll be having them checked tomorrow. If anyone has any other ideas please let me know. Thanks
 

·
Registered
Joined
·
9 Posts
I just got done with a similar issue. It turned out to be my steering gear box went out. Since the power assist to the brakes is on the same system as the power steering pump and steering gear box it pumped the metal shavings up into the hydro boost for the brakes. I am guessing it wrecks havoc with the pistons, seals, etc in the booster, but it acted the same. Couple diagnostic tricks...pull the ABS fuse and should have standard braking without the issue....check the power steering reservoir with a magnet for metal. I believe there is a TSB for contaminated fluid ruining boosters, but it doesn't address the source which would have to be the gear box or pump.
 

·
Registered
Joined
·
119 Posts
I know this is old but I have this issue too. I'm going to stick a magnet in there... Im pretty sure my steering box is on the way out. Hope I don't ruin the booster too.
 

·
Registered
Joined
·
680 Posts
Was just browsing and came across this post. Mine did the exact same thing last week after a 700+ mile rode trip(started 30miles before i made it home). I hope it isn't my steering box as this would be the 4th Redhead Box I put in in 2-1/2yrs.
 
1 - 4 of 4 Posts
Top