Ford Powerstroke Diesel Forum banner

1 - 20 of 31 Posts

·
Registered
Joined
·
591 Posts
Discussion Starter #1
I just bought a 95 7.3 with 275,000 miles and its completely stock. When you first start it runs a little rough and smokes white smoke for a good bit of time. And has a little miss idling and at around 1100 rpm. But when it gets up to temperature the miss goes away. I enclosed a video if that helps.

https://www.youtube.com/watch?v=KgYOHieKJss&feature=youtube_gdata_player

I know my glow plug relay is working. So I think I might be the glow plugs, or maybe the injectors considering the miles. But any and all advice is appreciated.

Thanks in advance.
 

·
Registered
Joined
·
496 Posts
jesus that truck is clean - and there seems to be alot of this going around. my opinion would be yes - if it not real cold out where you are - but im not expert.. i wanna swap my injectors out too

edit - my glow plugs and gpr are newer, so are the valve cover gaskets -and my 95 doesnt do that when i start in the morning in my jersey temp.
 

·
Registered
Joined
·
591 Posts
Discussion Starter #4
jesus that truck is clean - and there seems to be alot of this going around. my opinion would be yes - if it not real cold out where you are - but im not expert.. i wanna swap my injectors out too

edit - my glow plugs and gpr are newer, so are the valve cover gaskets -and my 95 doesnt do that when i start in the morning in my jersey temp.
Thanks, I got it from an older guy who had owned it for 11 years and had it since it had 174k miles on it. He kept the oil changed every 5k miles and kept it clean. It's not a show truck by any means but I think it's real nice for what it is.

I also done a battery check on it tonight and it's due for some batteries as well.
 

·
Premium Member
Joined
·
595 Posts
I would try running a good fuel additive in it before changing injectors. I like Stanadyne Performance Formula. It may help, may not, but definately wouldn't hurt it any.
 

·
Registered
Joined
·
1,482 Posts
When I got my truck it did the samething it was 2 gp that wouldn't light replaced all of them and a new valve cover gasket and all was good
 

·
Registered
Joined
·
1,035 Posts
I would try running a good fuel additive in it before changing injectors. I like Stanadyne Performance Formula. It may help, may not, but definately wouldn't hurt it any.
Is that a good one? Or diesel kleen? I may run some in mine. I bought her a few months ago..never had a start issue. Today it was about 50. Rig fired right up. I put the kid in got in, she hadbeen idling for maybe 5 min. Hit the headlight switch to parking lights and she shut off on me. Kinda strange. Fired right back up and off we went. I think i got some white smoke on startup also. But it was dark and hard to tell with my red neck exhaust
 

·
Banned
Joined
·
5,630 Posts
before you do anything, ohm out the glow plugs, ohm out the glow plug relay, and CLEAN the fpr screen. When my fpr screen filty, I thought my gp's and gpr were shot (which are relatively new...)

Diesel kleen should be ran thru every tank to help w/ lubricity. I get 2-3mpg better using diesel kleen.
 

·
Registered
Joined
·
591 Posts
Discussion Starter #9
The guy who I bought from ran diesel kleen in it every tank.
Do I need to take the valve covers off to ohm out the glow plugs? And what should they ohm out to be?
 

·
Banned
Joined
·
5,630 Posts
The guy who I bought from ran diesel kleen in it every tank.
Do I need to take the valve covers off to ohm out the glow plugs? And what should they ohm out to be?




PLEASE clean your FPR screen before you make ANY assumptions on things going bad.
 

·
Premium Member
Joined
·
595 Posts
Is that a good one? Or diesel kleen? I may run some in mine. I bought her a few months ago..never had a start issue. Today it was about 50. Rig fired right up. I put the kid in got in, she hadbeen idling for maybe 5 min. Hit the headlight switch to parking lights and she shut off on me. Kinda strange. Fired right back up and off we went. I think i got some white smoke on startup also. But it was dark and hard to tell with my red neck exhaust
I like it best out of the additives I have used. It is quite a bit more expensive, but it is the only one that I could tell a difference with. It just seemed to make the truck run smoother.
 

·
Registered
Joined
·
591 Posts
Discussion Starter #13
Well i checked my glow plug relay and its good. I ohmed out the glow plugs and the all ohmed out at around 1 ohm. I check my FPR screen and it was gummed up, cleaned it. Check my fuel pressure, it's at 50 psi idling.

And it still smokes on start up a bit. Also checked my batteries and they pulled a 28 on the driver one and a 38 on the passenger one.
 

·
Registered
Joined
·
705 Posts
I like it best out of the additives I have used. It is quite a bit more expensive, but it is the only one that I could tell a difference with. It just seemed to make the truck run smoother.
Do you put some of that in every tank? or just every couple of tanks?
 

·
Registered
Joined
·
496 Posts
Do you put some of that in every tank? or just every couple of tanks?
i have no experience with that, but my compnay uses an additive from GUMOUT i belive on its fleet. i think using anything is better than nothing. speaking of which - i have to put some in my own tank. another good idea , or so ive heard, is to get fuel from a few different locations instead of just one. hard to do sometimes, cause i only have one station thats convient for me to goto with diesel..

i certainly wish a station over here woould start selling biofuel.. they would make a killing - NOBODY out here sells it.
 

·
Registered
Joined
·
591 Posts
Discussion Starter #16
Well I plugged my truck in last night and my truck didn't smoke a bit. And I decided to check blow by, it's seems to have blow by. I laid the oil cap upside down over the oil fill hole and it did not blow the oil cap off.
 

·
Registered
Joined
·
591 Posts
Discussion Starter #17
Anyone else?
 

·
Banned
Joined
·
5,630 Posts
Well i checked my glow plug relay and its good. I ohmed out the glow plugs and the all ohmed out at around 1 ohm. I check my FPR screen and it was gummed up, cleaned it. Check my fuel pressure, it's at 50 psi idling.

And it still smokes on start up a bit. Also checked my batteries and they pulled a 28 on the driver one and a 38 on the passenger one.
You cant check a dual battery setup on these trucks w/ the batteries connected. You'll never get an accurate reading. Aside from that, a puff of smoke on startup is fine.. especially if the truck isn't driven often.

Do you put some of that in every tank? or just every couple of tanks?
I use diesel kleen every single tank. It makes noticeable difference in power and mpg.
 

·
Registered
Joined
·
591 Posts
Discussion Starter #20
You cant check a dual battery setup on these trucks w/ the batteries connected. You'll never get an accurate reading. Aside from that, a puff of smoke on startup is fine.. especially if the truck isn't driven often.
I checked both batteries separate and off the the truck. So my truck is more than likely fine?
Would you say that the injectors are due for a changing with 274k miles on them?
 
1 - 20 of 31 Posts
Top