Ford Powerstroke Diesel Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
127 Posts
Discussion Starter #1
Having issues and not sure what might be the cause.

Last week I got off the freeway and the truck had no power and started to black smoke and no boost. P1335 Code. Stuck EGR.

Came home, pulled the EGR valve which was completely full of carbon. Cleaned and reinstalled. Did NOT replace O rings. Everything inside was dry. There was oil in the intake, and a little puddle sitting right in front of the turbo. Oil residue all around the base of the turbo.

Drove next day and had black smoke under heavy acceleration, but had the power back. Occasional white smoke on startup only. Brought home again and changed the oil and did fuel filters, both were Looooong overdue.

Pulled EGR valve again to have a look. More carbon on it, but this time everything inside was wet. Decided to replace the EGR valve.

Drove it for a day. No white smoke AT ALL. Black smoke still there under heavy accel only. Even after clean oil and new filters. But again, no white smoke.

This morning, I go to take off and have tons of white smoke. Turned it around at the end of the street and parked it.

I do have very minor coolant loss, but no puking from the tank, and my deltas have always been awesome. At 65mph, I'm usually 4 to 6* off at most. Usually I'm right at 5* most all of the time.

Any ideas on what it might be and what ? can do? I want to get this taken care of ASAP, as I need the truck, but don't want to turn it into a head gasket situation.

Much appreciated! :)
 

·
Registered
Joined
·
4,914 Posts
Wet inside the intake is usually egr cooler failure. How are you monitoring deltas?

Sent from my phone that somebody didn't help me get.
 

·
Registered
Joined
·
6 Posts
Agreed.. just finished fixing the same issue on my truck. (2005 f250 6.0 85,000 miles.) Truck only used a little coolant because when it did smoke white I quit driving it.. I continued using the truck with the same situation you have and it hydro-locked. Turned out to be a bad egr cooler which can be caused by the oil cooler. I had both replaced and upgraded to bullet proof diesel's products and had to have the work done by a shop due to the hydro-lock. Cost me $4000 to fix after parts and labor. My advice to you; don't drive it until you can have the egr cooler and oil cooler replaced.
 

·
Registered
Joined
·
127 Posts
Discussion Starter #4
Monitoring with the Banks IQ. Again, I have NEVER seen it more that 5 or 6* off unless it was just for a few seconds after going from like 75mph to a stop where it will obviously take a minute for the oil temp to drop.

And yeah, I definitely don't want to drive it until I can fix it. I'd like to do so this weekend.
 

·
Registered
Joined
·
127 Posts
Discussion Starter #5
I'm also really surprised because I run a oil bypass filter and and a coolant filter also.
 

·
Registered
Joined
·
127 Posts
Discussion Starter #6 (Edited)
I did go way over on my oil change though. I was at 15k on that oil at that time. I'm sure even with full synthetic and a bypass, that's still a big no-no. Any way the oil cooler is still good and it's just the EGR cooler? Oil temps are around 200 and delta is only about 5* off. I'd live to do the Bullet Proof Oil Cooler and EGR, but they want $2k for that kit, and I can't really afford that right now. Can I change the oil screen and put on just the BPD EGR?
 

·
Registered
Joined
·
1,621 Posts
90 perent sure its the egr cooler the oil cooler doesnt have to go back for the egr cooler to go. if your using ford gold coolant it can still kill egr coolers
 

·
Registered
Joined
·
127 Posts
Discussion Starter #8
yup. Ford Gold is what it is.
 

·
Registered
Joined
·
6 Posts
It dosent necessarily have to be replaced but normaly it is the cause of the egr coole failure.. If you have a filter it may have just been caused by the cruddy ford coolant and high egts. If you can afford the bullet proof egr then you may also want to look at an oem cooler they run around $350. And again that's what I had to do it dosentean you have the exact same problem.
 
1 - 9 of 9 Posts
Top