Ford Powerstroke Diesel Forum banner
64361 - 64380 of 64407 Posts

·
Registered
Joined
·
1,070 Posts
The assholes still running around in there. Licked the peanut butter off the traps. Shutting everywhere. ****!
Bucket of water with hinged diving board, peanut butter on the end over the water. He goes to get peanut butter diving board dumps him into water and he drowns.

Sent from my SM-G973W using Tapatalk
 

·
Registered
2003 F350 ECSB
Joined
·
42 Posts
Bucket of water with hinged diving board, peanut butter on the end over the water. He goes to get peanut butter diving board dumps him into water and he drowns.

Sent from my SM-G973W using Tapatalk
id like to try this
 

·
Registered
Joined
·
1,070 Posts
id like to try this
Works well - caught many mice and rats this way. They can't tread water forever.



Sent from my SM-G973W using Tapatalk
 
  • Like
Reactions: jokester00

·
Registered
Joined
·
793 Posts
I have had my truck for almost 2 years and 19k mile (159k on the clock). It took me that long to get a Glow Shift Fuel pressure gauge. I did the blue spring right away though.😁. I thought all was good with 64# at idle. A quick trip down the road with a WOT pass proved me wrong. The pressure dropped to 20 psi 😬. $400 later there’s a new HFCM and 58 psi at WOT.

Gentlemen, don’t wait to put a fuel gauge on you truck.
 

·
Premium Member
2006 F350 SuperCab, 4x4, AT, Cab & Chassis, 9' flatbed, dually, studded/egr deleted
Joined
·
650 Posts
I have had my truck for almost 2 years and 19k mile (159k on the clock). It took me that long to get a Glow Shift Fuel pressure gauge. I did the blue spring right away though.😁. I thought all was good with 64# at idle. A quick trip down the road with a WOT pass proved me wrong. The pressure dropped to 20 psi 😬. $400 later there’s a new HFCM and 58 psi at WOT.

Gentlemen, don’t wait to put a fuel gauge on you truck.
Too late. :-(

And 3 fuel pumps gone. Nope have a factory pump in.
 
  • Wow
Reactions: jokester00

·
Premium Member
Joined
·
2,776 Posts
The assholes still running around in there. Licked the peanut butter off the traps. Shutting everywhere. ****!
Chew up a tootsie roll candy and stick a small chunk on the trap. They cannot resist, and also cannot remove it easily. Best bait ever for rats and mice.


@Flamed99


Sent from my iPhone using Tapatalk
 

·
Registered
2003 F350 ECSB
Joined
·
42 Posts
I caught the little ****. He was making a nest above the heater box. Had a trap set on the battery with string wrapped around trigger coated in peanut butter so it would pull at it. Went out this morn and dead.
luckily he didn’t chew anything up as far as I could tell. I had enough napkins and junk in the glove box that kept him happy.
 

·
Premium Member
2006 F350 SuperCab, 4x4, AT, Cab & Chassis, 9' flatbed, dually, studded/egr deleted
Joined
·
650 Posts
Yesterday I was able to install a camshaft position sensor, cleaned my EBP sensor, ran the truck to clean out the tube, and this morning it wouldn't start. The error code is the cam position sensor, even though it ran yesterday... Must be the harness...
 

·
Premium Member
2006 F350 SuperCab, 4x4, AT, Cab & Chassis, 9' flatbed, dually, studded/egr deleted
Joined
·
650 Posts
I overlayed the connector wire from the camshaft position sensor to the ECM plug, and drove my truck home.

Hand Pliers Finger Wood Font
Hand Finger Gesture Thumb Tool
Motor vehicle Hat Bag Electrical wiring Gas
Automotive tire Motor vehicle Electrical wiring Automotive fuel system Gas
Handwriting Finger Gesture Thumb Nail
Font Circle Electronic device Asphalt Automotive tire
Font Material property Parallel Pattern Rectangle
 

·
Premium Member
2005 F250 FX4 Lariat CCSB - ARP studs, EGR deleted, IPR coolant filter
Joined
·
396 Posts

·
Premium Member
Joined
·
3,583 Posts
Bucket of water with hinged diving board, peanut butter on the end over the water. He goes to get peanut butter diving board dumps him into water and he drowns.

Sent from my SM-G973W using Tapatalk
OR....you spray him with brake kleen and light him on fire! 😁

🤣🤣🤣🤣

-jokester
 

·
Premium Member
2006 F350 SuperCab, 4x4, AT, Cab & Chassis, 9' flatbed, dually, studded/egr deleted
Joined
·
650 Posts
Cool monitoring display. What are you using for that. Looks like Torque. Does your Gear indication work properly?
Yep, torque. Just changed the back ground.

And I'm not sure on the gear. When I'm at idle, it shows .5 gear...
 
  • Like
Reactions: MtnTallPaul

·
Premium Member
2005 F250 FX4 Lariat CCSB - ARP studs, EGR deleted, IPR coolant filter
Joined
·
396 Posts
Yep, torque. Just changed the back ground.

And I'm not sure on the gear. When I'm at idle, it shows .5 gear...
Pretty sure the transmission in my 05 Super Duty is a five speed. The display on Torque goes from 3 to 5, never displaying 4.
 

·
Registered
2003 F350 ECSB
Joined
·
42 Posts
got a new alternator in. fixed my dead battery issue. it sure does look prettier than the old one. id like to give the old gurl a little purdyin soon. make a mesh grill, do some sort of bumper, its an 03 front end, any suggestions on what bumpers look good? i like stock but i hate all the plastic **** on them. as well as rear bumpers any ideas on those. also contemplating a reverse level.
 

·
Registered
Joined
·
168 Posts
Went to drive my truck and realized that my DS taillight was out. These are new LED's so I was kinda surprised. I got ready to remove the plug and all of sudden the light worked. I realized that the the plug in on the truck had 2 parially broken wires. No place local to get the plug so I ran the wire directly to the harness on the lights and it works. I guess after the holidays I'll go shopping for another plug (or not).
 

·
Premium Member
Joined
·
2,776 Posts

·
Premium Member
2006 F350 SuperCab, 4x4, AT, Cab & Chassis, 9' flatbed, dually, studded/egr deleted
Joined
·
650 Posts
So you seemed to have tracked down the pesky problem. At least you found the smoking gun.


Sent from my iPhone using Tapatalk
Seems like it. I made it home alright - even had a little more pep, it seems like. But I also cleaned out the EBP sensor and tube and had been driving a 2009 F150 for the past week. Regardless, it was good to be back driving it.

I hope to get the newer starter and alternator installed one of these mornings..
 
  • Like
Reactions: TwinExcursions

·
Registered
Joined
·
1,070 Posts
Pretty sure the transmission in my 05 Super Duty is a five speed. The display on Torque goes from 3 to 5, never displaying 4.
That is how they are programmed, I can't remember correctly the pattern for when 4th gear comes into operation but I think it is extreme cold weather.

Sent from my SM-G973W using Tapatalk
 
  • Like
Reactions: MtnTallPaul
64361 - 64380 of 64407 Posts
Top