Ford Powerstroke Diesel Forum banner

63861 - 63880 of 63905 Posts

·
Registered
Joined
·
1,098 Posts
  • Like
Reactions: TwinExcursions

·
Registered
Joined
·
640 Posts
Not much, just topped up the coolant today. It took just about a full jug. First top-up in about a year. A few weeks back when the weather was colder, the heater was blowing cool air at idle. I didn't think it was a low coolant issue because it was visible in the reservoir. However, it took the jug I added. Here's a question; Is it normal for the coolant level to go down in the reservoir when engine is running, then come back up when shut off? This truck has always done that.
 

·
Blow me to Bermuda!
Joined
·
741 Posts
Pioneer W4660NEX + Backup & Forward-Facing Camera + Steering Wheel adaptor.

Speakers coming on Tuesday...or Wednesday. Ordered some entry-level Focals to replace my OEM speakers. Got a deal from a friend I couldn't say "no" to.
 

·
Blow me to Bermuda!
Joined
·
741 Posts
Not much, just topped up the coolant today. It took just about a full jug. First top-up in about a year. A few weeks back when the weather was colder, the heater was blowing cool air at idle. I didn't think it was a low coolant issue because it was visible in the reservoir. However, it took the jug I added. Here's a question; Is it normal for the coolant level to go down in the reservoir when engine is running, then come back up when shut off? This truck has always done that.
Mine fluctuates with Hot / Cold. But the levels are consistent. (For the most part.)
 

·
Premium Member
Joined
·
2,851 Posts
Not much, just topped up the coolant today. It took just about a full jug. First top-up in about a year. A few weeks back when the weather was colder, the heater was blowing cool air at idle. I didn't think it was a low coolant issue because it was visible in the reservoir. However, it took the jug I added. Here's a question; Is it normal for the coolant level to go down in the reservoir when engine is running, then come back up when shut off? This truck has always done that.
The bigger question was...why did you have to top off the coolant and where is it going?

About the level fluctuation: My truck did that as well when my coolant was low, until I finally got the level correct. Top off to the correct level when the truck is cold and sitting on level ground. After that, you should never see the level decrease at all. It might fluctuate and increase a bit, depending on ECT & coolant pressure, but should never decrease once level is set cold unless it's going somewhere...

-jokester
 
  • Like
Reactions: TwinExcursions

·
Premium Member
Joined
·
2,501 Posts
Very strange that this topic still doesn’t show up on my feed. I have to search for it. Frustrating!!


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
1,493 Posts
Very strange that this topic still doesn’t show up on my feed. I have to search for it. Frustrating!!


Sent from my iPhone using Tapatalk
Same here, ever since @junior125 messed it up, lol. Funny thing is, my personal and biz phone are messed up, tried deleting and installing the app and signing out too. But i got a new tablet, and it showed up fine once i got the app and signed in.

Sent from my LM-G820 using Tapatalk
 

·
Premium Member
Joined
·
1,493 Posts
Not much, just topped up the coolant today. It took just about a full jug. First top-up in about a year. A few weeks back when the weather was colder, the heater was blowing cool air at idle. I didn't think it was a low coolant issue because it was visible in the reservoir. However, it took the jug I added. Here's a question; Is it normal for the coolant level to go down in the reservoir when engine is running, then come back up when shut off? This truck has always done that.
If you service the coolant system, and dont use the vacuum fill method, it could take some time to burp the air out. But not a year. If its at the proper level when cold, then you get it warm and open the cap, the level will rise in the tank. Once it cools it should be back where it was prior. Could very well have a small leak in a coolant line somewhere that just evaporates and doesn't leave a trail. Or blown head gaskets, lol.

Sent from my LM-G820 using Tapatalk
 

·
Registered
Joined
·
600 Posts
Drove it for work 500 mile round trip including logging roads. I think it liked cruising at 75mph for hours.

Sent from my SM-G973W using Tapatalk
 

·
Super Moderator
Joined
·
10,112 Posts
Same here, ever since @junior125 messed it up, lol. Funny thing is, my personal and biz phone are messed up, tried deleting and installing the app and signing out too. But i got a new tablet, and it showed up fine once i got the app and signed in.

Sent from my LM-G820 using Tapatalk
:banhammer::wall:


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
1,493 Posts
:banhammer::wall:


Sent from my iPhone using Tapatalk
Uh, not scared. You know its just the few of us that were active, when u did what u did, that its messed up on, and only on Tapatalk i believe, so i cant let you live it down.

Sent from my LM-G820 using Tapatalk
 

·
Super Moderator
Joined
·
10,112 Posts
Uh, not scared. You know its just the few of us that were active, when u did what u did, that its messed up on, and only on Tapatalk i believe, so i cant let you live it down.

Sent from my LM-G820 using Tapatalk
I’m still not even sure it was me that nuked it from orbit originally, and at this point a large portion of 12oz curls have occurred, but I at least brought it back


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
1,493 Posts
I’m still not even sure it was me that nuked it from orbit originally, and at this point a large portion of 12oz curls have occurred, but I at least brought it back


Sent from my iPhone using Tapatalk
I cant say who started it all, but you halfway admitted to it so i ran with it. But you did save it so that's worth something. Maybe next time it comes up ill lead off with, "atleast @junior125 saved it, after someone , erased it".

Its still frickin weird how its screwed up for some but not all. And not across all devices.

Sent from my LM-G820 using Tapatalk
 

·
Super Moderator
Joined
·
10,112 Posts
I cant say who started it all, but you halfway admitted to it so i ran with it. But you did save it so that's worth something. Maybe next time it comes up ill lead off with, "atleast @junior125 saved it, after someone , erased it".

Its still frickin weird how its screwed up for some but not all. And not across all devices.

Sent from my LM-G820 using Tapatalk
To be fair my tapatalk has been goofy since before then, but at least the thread isnt in purgatory or whatever happened to it when the mods were sipping on the ole windex


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
2,501 Posts
I got a new phone right after it happened, but dropped it and couldn’t get it fixed before my rafting trip, so just bought a new phone for the trip. Never came back on all 3 phones. Lol


Sent from my iPhone using Tapatalk
 
63861 - 63880 of 63905 Posts
Top