Ford Powerstroke Diesel Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
298 Posts
Discussion Starter #1
When I turn my windshield wipers on my truck shuts off. But it only happens when it rains which is messed up cuz that's the only time I need them. It'll do it when I'm goin 5mph or 80mph. But when I'm goin fast enough the truck will shut off for a second and then turn back on. Where in the hell would I even start to look for a problem??


Sent from my iPhone using Autoguide
 

·
Registered
Joined
·
180 Posts
Its your CPS. No ifs ands or buts about it.

Replace it with a Motorcraft unit only.
 

·
Registered
Joined
·
298 Posts
Discussion Starter #3
Just to clarify you mean my crank position sensor?


Sent from my iPhone using Autoguide
 

·
Registered
Joined
·
1,888 Posts
im thinking the GEM module. Their notorious of get'n wet, when it rains. Its because the factory seal aroundthe windshield sick arse. Either replace the windshield and/or re-seal the one you got...if possible
 

·
Registered
Joined
·
11,152 Posts
CPS is cam sensor.
I'd say either that, GEM, or wiring in the steering column.
 

·
Registered
Joined
·
180 Posts
Just do the CPS first lol. I've seen it a million times.
 

·
Winning DUHHH
Joined
·
2,389 Posts
It's the gem, windshield leaks causing water to run into it. And you only use your wipers when it's wet out :) your going to waste money on a cps, get a gem


Sent from my iPhone using Autoguide
 

·
Registered
Joined
·
2,729 Posts
If your running a DP Tuner and the wire running from the chip to the switch is too close to electrical interference it can cause the same issue.
 

·
Registered
Joined
·
180 Posts
It's the gem, windshield leaks causing water to run into it. And you only use your wipers when it's wet out :) your going to waste money on a cps, get a gem


Sent from my iPhone using Autoguide
lol CPS: $30
PCM: $300+

Start with the CPS...
 

·
Winning DUHHH
Joined
·
2,389 Posts
If its the cps, whys it only do it wet?
Search for his issue, 99% of the issues was the water leaking onto the gem they figured the wipers are what caused it, but realized it was water


Sent from my iPhone using Autoguide
 

·
Premium Member
Joined
·
8,676 Posts
It not the Wet,,, it has nothing to do with water, it's the Wiper Motor causing electrical interference that's effecting the CPS.

http://www.powerstroke.org/forum/99-03-7-3-motor-problems/13006-stumbles-when-rains.html

You can either replace the CPS (which isn't really bad, just sensitive to the failing wiper motor) or replace the wiper motor (CPS is probably cheaper & easier) OR suppress that interference with Ferrite Beads or caps or something,,, (I confess I'm not sure what it takes for sure).

If it were me, I'd take the challenge of trying to filter out the interference, but, Yea, changing the CPS should do it ;)
 

·
Registered
Joined
·
298 Posts
Discussion Starter #12
CPS is cam sensor.
I'd say either that, GEM, or wiring in the steering column.
That's what I meant I apologize. That won't be so bad since I have one or two extra laying around here somewhere. I have a IH one and 2 motorcraft. Are the IH ones junk? It's the gray one. Not the purple(?) one.


Sent from my iPhone using Autoguide
 

·
Registered
Joined
·
298 Posts
Discussion Starter #14
I thought it was the purple one that was junk. Oh well. $30 ain't bad.


Sent from my iPhone using Autoguide
 

·
Registered
Joined
·
1,888 Posts
I thought it was the purple one that was junk. Oh well. $30 ain't bad.


Sent from my iPhone using Autoguide
purple, blue, grey, pink...there's "graphs", believe from wood-n-things, doing a perdel readout. You'll see, plus the black lowers the #8 noise to almost nn existence
 

·
Registered
Joined
·
180 Posts
If its the cps, whys it only do it wet?
Search for his issue, 99% of the issues was the water leaking onto the gem they figured the wipers are what caused it, but realized it was water


Sent from my iPhone using Autoguide
Im not sure. I have never been able to replicate the symptoms. Now that I have a full nights sleep I can think clearly. The wiper issue was only an issue with aftermarket CPS'. If the OP's CPS is factory then it probably is the PCM, but I would still try the CPS first if he isnt sure of the history of it. It's a lot cheaper.
 

·
Registered
Joined
·
298 Posts
Discussion Starter #19
If I remember correctly it is an aftermarket CPS. I'm not sure it's been so long since I messed with it.


Sent from my iPhone using Autoguide
 

·
Registered
Joined
·
180 Posts
If I remember correctly it is an aftermarket CPS. I'm not sure it's been so long since I messed with it.


Sent from my iPhone using Autoguide
Ding ding ding ding. We have a winner. :crazy:
 
1 - 20 of 25 Posts
Top