Ford Powerstroke Diesel Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2,107 Posts
Discussion Starter #1
So a few weeks ago I started having a weird trans shifting issue. It is very sporatic. When I first start the truck and put the truck in drive I will go to hit the gas and the truck will almost stall out. We have scanned the truck with both a ford scanner and a snap on scanner and it says TCS (tranny control switch malfunction). We went through the whole wiring system and found that the TCS is in fact good. This was a pain in the arse. We pulled the whole dash and went through everything. It is very sporatic so this was a chore in and of itself since we would have to start the truck over and over to force the truck to do it several times so that we could get everything tested. Tech seems to think it could be the TCM causing the issue now since everything else checks out. What does everyone think? Also over the last two weeks I have been paying close attention to when exactly it does it, and it seems as if 99% of the time it will do it if I put the truck in reverse first to back out of a parking spot, then go into drive.
 

·
Registered
Joined
·
1 Posts
I am having the exact same problem now. Anyone know what it could be? The truck will die sometimes. I shift from park to drive or reverse and barely start to push the gas pedal down and it will die. Starts right back up and idles fine. NO codes. I can make it not die if I give it more pedal than normal when taking off or backing up.
 

·
Registered
Joined
·
37 Posts
So a few weeks ago I started having a weird trans shifting issue. It is very sporatic. When I first start the truck and put the truck in drive I will go to hit the gas and the truck will almost stall out. We have scanned the truck with both a ford scanner and a snap on scanner and it says TCS (tranny control switch malfunction). We went through the whole wiring system and found that the TCS is in fact good. This was a pain in the arse. We pulled the whole dash and went through everything. It is very sporatic so this was a chore in and of itself since we would have to start the truck over and over to force the truck to do it several times so that we could get everything tested. Tech seems to think it could be the TCM causing the issue now since everything else checks out. What does everyone think? Also over the last two weeks I have been paying close attention to when exactly it does it, and it seems as if 99% of the time it will do it if I put the truck in reverse first to back out of a parking spot, then go into drive.
Did you ever figure it out?
 
1 - 3 of 3 Posts
Top