Ford Powerstroke Diesel Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
178 Posts
Discussion Starter #1
I have talked to as many people as I can about this but no one seems to know why it is doing it. Since the trans was rebuilt my 2001 7.3L has had a very unique idle while in gear after heating up a bit. It idles normal when the engine is cold in the mornings or on a cool day but if its hot out and I'm doing a lot of city driving it starts to do it. The idle jumps from 700-1000 roughly, it sits on the lower RPM for about 3 seconds then jumps up to 1000 and falls back down to 700 and repeats, if I take off when the RPMs are that low its really sluggish but a little bit of throttle pulls it out quick, it has never died doing this and while it is doing it if I pop it out of gear into N it idles like normal. I took it back to the shop that rebuilt the tranny and they said its nothing to do with the trans because if you put it into low/1 it still does it.


I don't have any gauges on it yet but should get my Edge Attitude monitor this weekend. I ran some Lucas Injector cleaner through the truck last tank and it seemed to mellow it down a little but did not get rid of it.

Any ideas?
 

·
Registered
Joined
·
178 Posts
Discussion Starter #2
Anyone? Looks like I may just have to take it and have a diag done... Crap.
 

·
Registered
Joined
·
28 Posts
Might want to check the ICP (injection control pressure) sensor. Located on top of the left head just in front of the lift hook. It screws into the head and has a wiring connector on top of it. Pull the wiring connector and see if there is oil inside of it.

If there is, replace this part (~$170USD). This controls the idle, although most idle problems occur at cold temps,. The symptoms sound similar.
 
1 - 3 of 3 Posts
Top