Ford Powerstroke Diesel Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
I have an 01 Ex with 7.3. I've done the DIY intake, 5" turbo back exhaust and have a DPTuner with 60hp,80hp,80 tow. I had to put a new turbo on a couple months ago I went with stock. Now when I get on it it sounds like the waste gate is opening more than it should. Is there an easy way to maybe keep the boost longer and keep the waste gate closed so as to not lose the power? Thanks
 

·
Registered
Joined
·
1,387 Posts
What boost #s are you seeing?
 

·
Registered
Joined
·
6,107 Posts
i think the stock wastegate opens at 10 psi lol
so i dont think you are hearing the wastegate open.
you could be hearing compressor surge?
 

·
Registered
Joined
·
1,387 Posts
If the waste gate opened at 10psi wouldn't that mean you could hear it a lot? I'd bet he is hearing the sound through the open element filter.
 

·
Banned
Joined
·
5,630 Posts
I dont think the OP is "hearing the wastegate". Post a video and I'll tell you what you are hearing.
 

·
Registered
Joined
·
1,387 Posts
If the waste gate opened at 10psi wouldn't that mean you could hear it a lot? I'd bet he is hearing the sound through the open element filter.
I just realized half my post made no sense. I bet he is just hearing the turbo whoosh that comes from the open intake. Highly doubt you are having WG issues. My truck kept hanging the wastegate and it was just a smokey pig and wouldn't spool.
 

·
Banned
Joined
·
5,630 Posts
^Thats why I said to post a video because I can almost guarantee he's not hearing the wastegate
 

·
Registered
Joined
·
45 Posts
Discussion Starter #10
If you guys are familiar with the old pressure cookers thats what it kinda sounds like when I get on it hard. That psss , psss, psss. If that makes since.
 

·
Registered
Joined
·
1,387 Posts
Probably surge, probably common.
 

·
Banned
Joined
·
5,630 Posts
Neeeeeeeed videossssssss.

It could be a dozen things, but I'm also leaning towards surge. Which is not good at all.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #14
Hey guys thanks for the replies. I read in another article on this forum that it's coming from the compressor wheel. I just ordered a whicked wheel and will let you guys know if that takes care of the problem, from what I've read it should. Thanks again!
 

·
Registered
Joined
·
45 Posts
Discussion Starter #15
Hey guys got my "whicked wheel" installed and Ex runs great with it! Smooth excelleration no surge good power, quicker. May have lost a pound or two on the top end but not that noticeable. I know because I have a gauge.
 

·
Registered
Joined
·
53 Posts
Same here. Installed the wicked wheel and a turbomaster controller last night. Did a total turbo removal so it would get done right. Had a bad oring/gasket between turbo outlet/spider, so had to wait to finish hatchin up tonight. Hopefully cures my issues as well.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #17
Some have also said to change out the wastegate with a Banks wastegate has anyone done this? If so what results did you notice?
 

·
Banned
Joined
·
5,630 Posts
Wont do a damn thing
 
1 - 19 of 19 Posts
Top