Ford Powerstroke Diesel Forum banner

1 - 14 of 14 Posts

·
Premium Member
Joined
·
11,892 Posts
i have a 05 6.0 powerstroke and lately i been hearing my turbo turn off and on and the boost goes to zero what could be going wrong
Turbo may need to be taken apart and cleaned. The unison ring inside may be sticking and causing your boost problem. Could also have a VGT solenoid that is weak. How many miles on truck? Do you ever run it hard or do you "putt" it around mostly?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
it has around 65k miles i drive it every day i usually punch it when i need to so i try to take care of it best i can where is the vgt solenoid located
 

·
Premium Member
Joined
·
11,892 Posts
it has around 65k miles i drive it every day i usually punch it when i need to so i try to take care of it best i can where is the vgt solenoid located
The solenoid is on the turbo itself. It is between the 2 halves of the turbo on top. It is the part with the white connector in the pic and the part laying on the ground is a spare.
 

·
Premium Member
Joined
·
11,892 Posts
it happens when im driving down the road you can hear it turn off and on and the boost goes to 0
The most common thing is for the unison ring to stick and cause your problem. Usually if it sticks the truck will have problems gatting up to speed and usually won't run faster than 50-60 mph depending on how bad the ring is sticking. You can remove the turbo and split the halves and clean the ring and mounting surfaces. Ford also has an updated unison ring that has a coating on it to prevent sticking.http://www.powerstroke.org/forum/6-0-repair-help/109150-cleaning-6-0-turbo.html
 

·
Premium Member
Joined
·
11,892 Posts
well the truck does it cruzing at 70mph it it turns on and off randomly
Do you actually have a power issue when it does it? Does it go all the way to 0? The PCM commands the VGT solenoid at all times how far to open or close the vanes. If you aren't having a power issue and just hearing it turn on and off, you could have a boost leak at one of the CAC tubes. They are prone to splitting and can cause some strange noises also.
 

·
Premium Member
Joined
·
11,892 Posts
there is a slite power problem when it happens yes the guage goes to 0
Ok, 1st thing I would check before removing turbo is all of your intercooler boots. Clean them off and feel around them for any cracks or holes. The blue one that comes off the turbo and connects to the passenger side intercooler tube is prone to cracking on the underneath side. Also check the boots that attach the intercooler pipes to the intercooler. If you can't find anything wrong, then your turbo is going to have to come out and be cleaned. You don't really see the VGT solenoids go bad since there are no moving parts.
 

·
Premium Member
Joined
·
11,892 Posts
ok will check all that in the morning thank you i will update this as soon as i find out something
Good luck.:thumb: Where are you located BTW? When you get a chance, go in and edit your signature so you can post up a pic of your truck and what you've done to it. Will also help later down the road if you have any problems, all of us can tell what kind of truck you have so you don't have to type all the info every time.
 
1 - 14 of 14 Posts
Top