Ford Powerstroke Diesel Forum banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
62 Posts
Discussion Starter #1
Hello guys, I am looking for some assistance with something.

I am replacing my stock turbo inlet piping that goes from the air filter to the turbo. At the same time I am replacing my PCV/Crankcase vent hose. The issue I am running into is the brand new PCV hose part#4C3Z6A603AA has 2 green orings on either end. The issue I am having is it is damn near impossible to jam the one end or the PCV hose into the intake pipe because the connection is so tight it just spits the green oring back out. There isnt a groove for an oring on the end that goes into the intake pipe anyway. Makes me wonder if the second oring is even suppose to be used. Has anyone out there replaced this before? I have attached a few pictures of the issue I am running into. I went back to Ford and the parts guy told me he had no clue. Asked the diesel technician at the Ford dealer an he said he doesnt know.

Thanks
Ryan






 

·
Premium Member
Joined
·
6,307 Posts
Ive never installed a new one but I doubt theres supposed to be an o-ring on that end, its just not made right for it. Now an o-ring does go on the end that goes into the valve cover.
 

·
Premium Member
Joined
·
62 Posts
Discussion Starter #3
Ive never installed a new one but I doubt theres supposed to be an o-ring on that end, its just not made right for it. Now an o-ring does go on the end that goes into the valve cover.
Yep to me it's just not made for an oring, it's odd put the parts guy checked a second PCV box an it too had a second oring. I do know there must be an oring on the valve cover side. Thanks anyway, I appreciate it.

Ryan
 

·
Registered
Joined
·
50 Posts
That silver clamp is a crimp clamp. It might be easier if you cut that clamp off and replace it after putting the PCV pipe in. I'm pretty sure there is only supposed to be the one green O ring and as port city says, it goes on the valve cover end.
 

·
Registered
Joined
·
182 Posts
@RY86

Did you ever get this figured out? I had to replace my turbo inlet and this PCV hose and am seeing the exact same thing. Did you ever confirm if it's simply an extra o-ring? I see no way for this part to be installed as implied with that o-ring there. My original part on my 2005 did NOT have this extra o-ring...that or it did and it's been eaten by the turbo.

My gut tells me that the PCV elbow has a rib on it and that is what seals inside the turbo duct. No clue why the additional o-ring is supplied.

Anyway...anyone know what the deal is with this?
 

·
SUCK SQUEEZE BANG BOOM
Joined
·
96 Posts
THEY ALL COME WITH TWO O-RINGS FORE SOME REASON, SAVE IT FOR A SPARE, JUST USE THE BUTTERFLY CLAMP, CRIMP WITH A PAIR OF SIDE CUTTERS, SOME BLACK SILICONE ON THE TUBE IS A GOOD IDEA TOO. THERE IS NOT SUPOSED TO BE AN O-RING IN THE INTAKE SIDE
 
1 - 7 of 7 Posts
Top