Ford Powerstroke Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hey guys. My 97 F350 manual came with an edge evolution which I promptly sold. I ordered a TS 6 pos with the standard tunes they come with. When I ordered it they asked me the year of my truck and the trans type. I went to put it in today, pulled my PCM, and it appears to have been replaced at some point in the trucks life. It has "1996 F250 Manual" written on it red paint pen (most likely from a wreckers I'm guessing). I installed the chip with no luck. Wait to start light won't come on and it just turns over and won't fire. Pull it out and it fires right away. I'm pretty confident I've cleaned the terminals well enough, I cleaned them about 8 times in my few hours of swearing and several attempts. Could it be the PCM/year issue? :confused:
 

·
BANNED by Kris
Joined
·
6,317 Posts
Do you KNOW what injectors you have? '96's definitely had single shot injectors but the '97's could have had multi-shot injectors (California trucks did but oil field trucks didn't). The '96 PCM may be hinting that you have aftermarket injectors installed (or the previous owner was too cheap to replace the injectors with multi-shots when he had an issue himself and found that working backwards was less expensive).

Just asking, you did clean both sides of the PCM contacts?
 

·
Registered
Joined
·
486 Posts
If it runs with out the chip it is still a single shot PCM and more than likely injectors, but the calibration will not be correct. You will need to have your TS re programmed for the 96 pcm.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4
Do you KNOW what injectors you have? '96's definitely had single shot injectors but the '97's could have had multi-shot injectors (California trucks did but oil field trucks didn't). The '96 PCM may be hinting that you have aftermarket injectors installed (or the previous owner was too cheap to replace the injectors with multi-shots when he had an issue himself and found that working backwards was less expensive).

Just asking, you did clean both sides of the PCM contacts?
Interesting .... is there any way to tell if I have aftermarket injectors? That would be nice if they were bigger. I'm from Canada ... Canadian truck ... if that makes a difference in which injectors it came with.

Yes I cleaned both sides very well, I pulled the PCM right out.

I have sent the TS back to be reburned for a 96, we'll see if that fixes it.

Thanks for your reply :beer:
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
If it runs with out the chip it is still a single shot PCM and more than likely injectors, but the calibration will not be correct. You will need to have your TS re programmed for the 96 pcm.
Thanks for replying Bryan. I bought it from you guys .... you should see it in a few days for the re-program. I was emailing with Scott and he asked me to call in and ask for you or Greg. Greg picked up and was very helpful .... but if I had known you were a 7.3 man I would have just asked for you :beer:

Thanks again!
 
1 - 5 of 5 Posts
Top