Ford Powerstroke Diesel Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
They have looked at several different things and are telling me now that the truck doesn't know what gear it is in and that is why it won't start. Seems weird to me!!!!!!! The dealership has now called Ford tech support to get help. They have changed a valve body in the transmission and a relay for the transmission. This hasn't cost me anything since it is still under warranty other than the $100 deductible and three weeks of down time. Does anyone have any ideas?
 

·
duct tape & zip ties
Joined
·
10,761 Posts
Neutral Safety Switch. TR range sensor is another thing to look at. But I think the Neutral safety switch and tr range sensor are together.
 

·
Registered
Joined
·
447 Posts
I am sure the techs at the dealership have tried everything they can and in no way would want to try and second guess what has been done or what they are doing as no one knows what they have tried. With that said, I had a similar problem on my tranny(4r100). Yours is a 5r110 so it is different. Checked all the wiring and connections,Took the valve body out, checked it, changed the range sensor still wouldn't work. Couple of days of searching later, I found out that the PCM from my truck had been taken out to try in another truck. Removed my PCM and found one of the pins on the PCM where the wiring harness plugs into the pcm was bent over. Fixed it and my problem was gone. Repeating again, I will not try and second guess them and I am in no way suggesting that this is your problem. I wrote all of this to tell you that I do feel your pain however in not having your truck. It sucks being without your truck. They are evidently scratching their heads on this one. They'll get it fixed.

BTW, Welcome to the ORG. Here's a bump back to the top for someone who might have some help for you.
 
1 - 3 of 3 Posts
Top