Ford Powerstroke Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
411 Posts
Discussion Starter #1
Getting ready to leave on a camping trip tommorrow pulling my 38' 5th wheel. Late today it began running rough. It has a very choppy idle and gets worse when I accelerate and is noticable the entire time I drive it. There seems to be no loss of power. I have no check engine lights. I put it on a scanner and there are no codes. I did an injector buzz test and cylinder contribution tests and they were all good. ICP at idle is 530psi, IPR duty cycle is 9% at idle. I had just replaced my gray cps with a black one so for the heck of it I switched them back, but it still is running very rough. I checked all the wiring harness I could find.. My fuel psi is holding steady at 62. I just fueled it up today and put in a Standyne fuel additive. I have ran out of ideas.. Any help?
 

·
Premium Member
Joined
·
9,390 Posts
the eps sensor or ebp sensor as it should be called will not cause a rough idle , if it passed a buzz test all wiring to injectors should be fine , ipr percentage is suposed to be at 14 % at idle and can cause a slightly rough idle if percentage is that low, i dont see a cps problem , either , sounds like youve done anything i would do , look at the icp sensor and unplug it , see if there is any oil leaking inside the sensor
 

·
Registered
Joined
·
411 Posts
Discussion Starter #6
After some extensive diagnosing today, I finally found the problem. #5 injector had a broken armature screw and so the truck was missing causing a rough idle.. I got it fixed and put back together and she's running great again!
 
1 - 6 of 6 Posts
Top