Ford Powerstroke Diesel Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
i have an 03 f350 4x4 6.0 and am having an issue nobody seems able to solve so far.
i have owned this truck a little more than a year. i purchased it to replace my 2001 7.3 that was wrecked with over 500k . when i bought it the engine had been replaced with a factory short block buildup. NO EGR, head studs new turbo etc. About two weeks before Christmas i was on the interstate going about 70 . The truck started stuttering and immediately started to cut off. i braked and the revs fell below 1600 and truck was fine . long story short when warm ,truck turns off between 1600-2000 rpm. before its warm no issues in power range at all.
here is what all has been done and to date no solution
new fuel filters, new fuel pump, new (rebuilt) ficm, rebuilt pcm, new ipr sensor,new wiring pigtail.
it has been scanned no codes , oil pump monitored throughout driving range normal until in 1600-2000 range then just cuts off, no issues starting. about out of parts to throw at it , have scoured web looking for similar issue to no avail. Any ideas appreciated.
 

·
Registered
Joined
·
83 Posts
If your IPR duty cycle spikes just before this thing stops running, You could very well have a High Pressure Oil Pump issue. The early design pumps sometimes have an issue where they just cant maintain pressure at high demand. At idle and low demand situations, they will run.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
thank you, i had him check that today. I will find out tomorrow but then again he didn't call so i might already have my answer. The great multi year experience i had with my 7.3 is certainly being tested by this 6.0....
 
1 - 3 of 3 Posts
Top