Ford Powerstroke Diesel Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
hey there, long time-first time... anyway, i was driving my 96 f250 down the road yesterday and it suddenly died. the tach dropped right off with no warning. no sputtering or hint of trouble. i pulled over and tried to start it again and right away i noticed no wait to start light, water in fuel light or fuel filter light as there is usually before you crank the motor. anyways i waited a few seconds and turned it over. it cranked as good as ever but wouldnt fire. so i towed it home and plugged the code reader in and it read "no response". my truck has the optional idle control module in the cab and i noticed it was reading "C-eRR". what the hell is going on here, i dont even no where to start. someone please help!!!
 

·
Registered
Joined
·
1,164 Posts
I would add as much info on your truck as you can, Chip Programe. etcAnd but no wait to start light usually means dead computer or fuel bowl heater is out check all your fuses.
 

·
Registered
Joined
·
1,164 Posts
Can you pull the programmer
 

·
Registered
Joined
·
1,164 Posts
Id check all your fuses and ensure there all good. But im pretty sure its your pcm might be bad hopefully someone will come around with more info. But prolly fuel heater or pcm
 

·
Registered
Joined
·
1,164 Posts
they can be reburned for like 40-60 dollars if there not ruined or like 150-200 i believe for a new one.
 

·
Registered
Joined
·
1,164 Posts
First id edit the post above people on here love to help but not when there jobs are said like that. But im not sure you can test it i know dp tuner reburns computers but it could take some time. If you need to have it fixed quick i think ford charges about 60-80 dollars
 

·
Registered
Joined
·
1,164 Posts
The stealership part
 

·
Registered
Joined
·
1,164 Posts
Im the same way, Not a big deal Just the guys that help out the most on here dont like it. Do you get power just no light, And are your fuses all good.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #16 ·
i got power, the battery light comes on and the odometer. from what i can tell, all fuses are fine in the the panel under the hood and in the cab.
 
1 - 16 of 16 Posts
Top