Ford Powerstroke Diesel Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
88 Posts
Discussion Starter #1 (Edited)
I've read through some threads and did a search, but found nothing similar to my situation.

last night my wife calls and said the truck is acting up (99.5 f250, 7.3, auto, 150,000 miles).

she said when she would let off the go pedal, it was like it had a jake brake (i wish). when she would take off from a light there was no power and once going it wouldn't shift into overdrive and the OD light would flash. temp was running between 170-200.

i took it for a drive when she got home and from a stop it sometimes seems like it's starting in 2nd, then will shift down to 1st and seems ok. sometimes it will shift into OD and other times you have to push the on/off button a few times. i never got the 'jake brake' effect like she stated but the trans did run at 170+.

i know without a test drive or seing it in person it's tough to trouble shoot, but any help is appreciated.
 

·
Registered
Joined
·
88 Posts
Discussion Starter #2
truck was towed to a Ford dealership, we'll be getting a new transmission installed (at our expense).

what did i do wrong?

the truck was used to tow our 28' 5th wheel camper trailer we bought last summer. if the highway was flat, i would cruise 70 mph +, with no worries. if i noticed a decent grade coming up i would shift it out of overdrive until we crested the hill and and leveled out again.

we have pulled the camper twice for a total of approx 800 miles.

now i need a new transmission......
 
1 - 2 of 2 Posts
Top