Ford Powerstroke Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 2005 F 250 6.0 has about 184,000 miles never have had any trans issues from this truck then today under normal driving conditions all of a sudden the tow/haul light started flashing and dash said trans temp so gauge on dash was reading nothing and my tuner was reading -66 when it normally reads around 140-150 to the positive. It acted like it was in tow/haul mode checked trans fluid and it smelled and looked fine and was full. Never had any leaks of any sort and have only towed boat a few times with it.

Shut truck off waited about 5 min and started it back up the tow/haul light was gone and my tuner was reading like it normally does but gauge on dash still had no reading. Anyone had this issue? If so what was it or does anyone have an idea of what it could be?

Thank you
Mike
 

·
Premium Member
Joined
·
560 Posts
I have a 2005 F 250 6.0 has about 184,000 miles never have had any trans issues from this truck then today under normal driving conditions all of a sudden the tow/haul light started flashing and dash said trans temp so gauge on dash was reading nothing and my tuner was reading -66 when it normally reads around 140-150 to the positive. It acted like it was in tow/haul mode checked trans fluid and it smelled and looked fine and was full. Never had any leaks of any sort and have only towed boat a few times with it.

Shut truck off waited about 5 min and started it back up the tow/haul light was gone and my tuner was reading like it normally does but gauge on dash still had no reading. Anyone had this issue? If so what was it or does anyone have an idea of what it could be?

Thank you
Mike
Transmission temperature sensor. Drop the pan and change the sensor and refil with 8 quarts of SP or IV. I actually just went through this same thing in my Excursion. Make sure you get a Ford part. They are way too cheap to do it twice. Walmart had the MaxLife in gallon jugs so 2 of them is what you will need unless you want to use Motorcraft fluid.

Sent from my SM-G965U using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thank you very much I appreciate the help with this. So the sensor you purchased from ford is that correct
 

·
Premium Member
Joined
·
560 Posts
Thank you very much I appreciate the help with this. So the sensor you purchased from ford is that correct
Correct, I forget how much but less than 20 bucks.

Sent from my SM-G965U using Tapatalk
 

·
Administrator
Joined
·
29,323 Posts
 
1 - 6 of 6 Posts
Top