Ford Powerstroke Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 03 f250 6.0 with tranny problems. On the first startup of the day in the morning the tranny acts up. I will pull out and the truck dosent want to shift into second. It will rev up and them bogg down at shifting point. It will do it two or three times then it will finally shift. After that the tow mode light is on and will not turn off. I have to pull over and turn the truck off and start it again. It works fine after that. It is a stock automatic transmission with around 100,000 miles on it. Also the transmission dosent overheat.Anybody have a guess to whats going on
 

·
Registered
Joined
·
4 Posts
I kinda have the same problem, just not as bad.
On the first start up of the day it doesn’t like to shift in to second gear, only after either riding the RPMs for a wile or after letting the RPMs drop it then shifts in to second gear. I only have to do that once and then for the rest of the day it just shifts smooth without any problems at all.

I assume it’s the solenoid, I just don’t know which one it is.

2004 6.0 F350
 

·
Registered
Joined
·
8,465 Posts
you need to take the truck to a transmission shop that knows the 5r100 plain and simple. tow/haul mode not turning off/flashing is a pre set warning system.

have you checked the fluid for color/smell?

have you checked for correct fluid level after truck is warmed up and running?

have you had any work/maintenance on the truck recently?

any mods? i.e. programmer, lift, tires, etc?
 

·
Premium Member
Joined
·
3,240 Posts
Yeah, sticky solenoid is likely the cause, the tow/haul light is flashing since the failed shift set a code
 
1 - 5 of 5 Posts
Top