Ford Powerstroke Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter #1
Alright, I've been away far too long. I'm back and need someone who really knows the wiring on these trucks. Here's the situation; both truck turn signals and brake lights work on the truck but only the left turn/brake works on the trailer. Here is my thought process so far. The trailer is fine, tried two dif trailers and same result both times. The fuse (13 and 14 if I remember correctly) in the passenger compartment is ok because one fuse per side for l or r turn, trailer turn and both brake. On to the power distribution box where I have switched the relays, both of which 'click' when the hazards are on. Both of them make the left trailer turn work and neither makes the right wink. The fuse in the power dist box can't be bad because one fuse (100?) Works both lights and only one is out. Ok, what am I missing? I am thinking chafed wire between cab and wiring harnes for trailer. Is there anything I need to check before I put a meter on the wire and try to trace it back to the cab and see where it gets hot? Anyone know a suspect chafe point for that wire if it is the case?
 

·
Registered
Joined
·
2,254 Posts
Isn't there a seperate fuse for each trailer signal light in the underhood fuse box? At least there is on my 06-I have a left trailer signal fuse, and a right trailer signal fuse in addition to the fuses for the truck.
 

·
Registered
Joined
·
69 Posts
Discussion Starter #3 (Edited)
From my read of the manual I have a.truck/trailer turn/brake fuse in the passengerbox one per side. I have a trailer relay in the power dist box for each side and a single fuse in the power dist for both and that's it... But I hope I'm wrong and its an easy fix! Anyone know?
 

·
Registered
Joined
·
69 Posts
Discussion Starter #4
Well I did it the old fashioned way and fixed it. - just climed down there and took 'er apart. The left wire and elect brake control wire had just fallen out of the socket! Has anyone ever see that before? On a new truck? Will Ford rebuild it? The wires look like all that holds them in is a little rubber 'stopper' and not even crimped in. I just don't want to be on the road and have a brake or even brake light go out because a wire simply falls out!
 

·
Registered
Joined
·
57 Posts
I'm having an issue also, everything on the truck works fine but no trailer brake lights and no trailer turn signals. I've checked the fuses, can't find any bad but haven't replaced the relays under the hood yet. It's not the trailer, checked that already. Anyone sell the relays or have to go to the Ford dealership? Going to pick up a trailer in the next day or two and need it fixed ASAP. I stopped by my local dealer last week but the line to get in to the service department was way backed up
and the wait was at least two hours.
 

·
Registered
Joined
·
50 Posts
I'm also having trouble..I dont have right turn signals on the back of truck or trailer...but I do have right turn signals on the front of truck...all fuses are good..
 

·
Premium Member
Joined
·
1,126 Posts
You all need to check the wiring at the female receptacle on the back of the truck. They are labeled as to which is which on the spring loaded cover. If you have no power at one (and you are grounding through the receptacle) then you need to start at the back of it where the wires enter the plug and go from there. First thing to check on wiring is always the ground. Check continuity between the ground in the plug and your frame. Sometime lights will work intermittently using the ground between the ball and hitch but it's not a reliable ground.
 
1 - 7 of 7 Posts
Top