Ford Powerstroke Diesel Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2009 f250 diesel with onboard TBC. When towing my 5th wheel i get no trailer braking when the brake pedal is applied. When I use the manual slide the trailer brakes work fine and I get a gain display in the control panel display. I get no indicator when using the brake pedal. I checked all fuses and all are good both under the hood and in the kick panel. The trailer is new 2013 and the truck has 16000 miles. All connectors at the trailer plug appears new and without any issues. I am baffled yet when searching the net see others with the same problem and other than a fuse or bad connector no real answers. Help.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
I see I have a lotta looks but no replies. Well for those interested in the trailer brakes not working, I took the truck to the dealer who has a diesel shop. The problem baffled them for a week. Finally they ordered the brake pressure transducer, new rear wire harness and a switch that goes to the cruise control. Basically most everything except the controller. A great shotgun approach on their dime. When I got it back it actually worked. Now I have brakes with the brake pedal and it displays on the dash.

The moral of the story, since i researched many sites on Google and never could find a fix. BTW the pressure switch was put in first and it still didnt work so the other parts were installed.
 
1 - 2 of 2 Posts
Top