Ford Powerstroke Diesel Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
127 Posts
Discussion Starter #1 (Edited)
Not sure where I'm losing coolant, but I am.

No visible leaks, no white smoke from the truck. Have not pulled the EGR valve, but did replace it 2 weeks ago. I fill the degas bottle to the max cold fill line. The correct max cold fill line as indicated by the sticker. A few days later the degas bottle is near empty, but never completely empty. It does not puke. No white stuff on the top of the bottle. Also Delta is in the 2* to 5* range. Hard to get it above 5* at any point. I also run a coolant filter.

Refilled it to the cold fill line today while it was still hot after driving it. Let it sit for about 5 hours and it was back down to that same spot again. I would be very surprised if there was air in the system, as the degas bottle was not completely drained.

Where could I be losing this stuff? I have the Blue hose on the EGR cooler and it does not appear wet around it. And why would I be losing it without the truck running and not see anything on the ground? Do they leak that slowly that it dries before it hits the ground? It is about 105* here.

I have heard the degas bottle can develop leaks. Where is that common at on the bottle?

Thanks in advance.
 

·
Registered
Joined
·
634 Posts
I have heard the degas bottle can develop leaks. Where is that common at on the bottle?

Thanks in advance.
Mine had a crack on the filler neck. Didn't see it until I used a magnifying lens.
 

·
Registered
Joined
·
128 Posts
Gonna have to pressure test the cooling system bud.
 
1 - 3 of 3 Posts
Top