Ford Powerstroke Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My 2001 F-350 has a couple of strange quirkes. The 1st is sometimes when I step on the throttle, there is no responce. The 2nd is sometimes when sitting in slow traffic (between 20 and 40 mph) and I'm only giving it a little throttle, my automatic transmission seems to up shift and down shift back and forth between 2nd and 3rd gear. I spoke with a friend of mine and he said the 1st problem is caused from a faulty TPS "throttle positioning sennsor", and he said the 2nd problem could be cured by replacing the transmission filter, but may also require replacing a vacum silinoid on the side of the transmission that looks like an egr valve. If anyone has any other advice for me, I'd appreciate it.
 

·
Banned
Joined
·
5,630 Posts
First problem def sounds like TPS.


When upshifting/downshifting, you are in traffic? Are you on any incline? Any load your pulling?
 

·
Registered
Joined
·
411 Posts
don't know if you have one, but i have a tuner and not a 6pos chip, but with it on high performance mine will shift funny, hammer it and it will go through the gears but just before 4th it will engage 4th, back to 3rd and then back to 4th, with it stock it doesn't do that at all. just throwing that out there.
 

·
Registered
Joined
·
9 Posts
I have the same exact problem. No throttle responce, and when it does, it kicks into 2nd and 3rd gear. It dosn't do it all the time, but when it does, it happens a few times, than goes away for a day or two.
 

·
Banned
Joined
·
5,630 Posts
Maybe the chip isn't connected tightly and getting good connection
 
1 - 5 of 5 Posts
Top