Ford Powerstroke Diesel Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
312 Posts
Discussion Starter #1
ok guys I need your thoughts. I just took my superchip max micro tuner off of my 95 F350 because i got my TS 6pos chip in the mail. I put the TS in expecting a lot more than my superchip. I started the truck and noticed that it runs smoother on startup, which was nice. but when i took it for a test spin it fell on its face. it has more power in 50 than in stock, and high idle works but when i put it on 75,100,140, it feels like someone just pinched my MAP sensor hose shut and it has no more power than 50. Do you guys think its a bad connection? I sure hope it is. my little 80hp superchip put out a lot more power and a LOT more smoke than my TS rated at 140+. can max out a 40psi boost gauge with the superchip and if im lucky ill hit 25 with the TS and with my injectors and upgrades that isnt making me too happy. What do you guys think is the issue? :dunno: Thanks
 

·
Registered
Joined
·
7,846 Posts
Well your problem is most likey since you said you have injector and other upgrades is that the chip you bought is canned tunes for a stock truck. Send your chip to a custom chip company and you will see the power for sure:thumb:
 

·
a truck
Joined
·
13,142 Posts
Are you sure you cleaned the connections well on the PCM?

Are you throwing an CELs?

Also I would highly suggest custom tunes as well, but it still seems like there is another issue
 

·
Registered
Joined
·
312 Posts
Discussion Starter #4
no CEL's but im kinda wondering about the connection, wether or not i cleaned it good enough. im goin to try cleaning it again after work and see if that helps. I used the little pad that comes with the chip. do you think i need to use something else? I just thought this chip would perform better than my superchip does with my injectors.
 

·
Registered
Joined
·
7,846 Posts
It should perform better. I used light sandpaper.
 

·
a truck
Joined
·
13,142 Posts
It should perform somewhat better, I would pick up some electrical connection cleaner and spray the connection with that and clean it off
 

·
Registered
Joined
·
312 Posts
Discussion Starter #7
i think im goin to get it retuned. im not happy with it the way it is. i dont know why my 1705 superchip would give my truck a lot more power than the TS but it does. hell maybe there was something wrong with my superchip, i dont know. it made the truck run like **** at start up but when i mashed on it it went. my TS makes my trans shift early into overdrive (at about 35mph) which causes the truck to lug down and it takes longer to get it up to speed. who do yall think is the best person to send my chip to and bout how much does that run$$$? thanks
 

·
Registered
Joined
·
804 Posts
tony wildman
 

·
Registered
Joined
·
7,846 Posts
Theres a few good ones. Cale, TW, PHP, Swamps, beans... im sure there is others.
 
1 - 10 of 10 Posts
Top