Ford Powerstroke Diesel Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
192 Posts
Discussion Starter #1
So, ever since the dealer replaced my oil cooler and deleted the egr the exhaust has been soooo smelly that it stinks up the front yard during warm-up. Any time you stop and open the doors the stink is there as well. Its just a super sting diesel exhaust smell that makes your eyes water.

Could this be their use of dino oil or something g to do with the delete or is this some other problem?
The truck is under warranty, so if it's injectors or something I'll get them replaced, but if it's oil I'll have time to change it out with the T6 in the garage.

Thanks for tour help guys and gals
 

·
Suck, Squish, Bang, Blow!
Joined
·
6,471 Posts
Has nothing to do with the type of oil...

Any visible smoke?

It's probably spilled oil or coolant burning off...
 

·
Registered
Joined
·
192 Posts
Discussion Starter #3
I forgot to mention. I'm fairly mechanically inclined. This smell is coming from the exhaust. Not oil burn off or any other residue burn off. It has been here for a 600 mile trip to NJ and back. It is the smell a poor running diesel truck makes.
There is only visible smoke during warm up. I willbhavebto inspect that better though. The only other visible smoke I get is when I lay into the throttle for the first time after not doing so for a week or so..
 

·
Administrator
Joined
·
21,558 Posts
I get it too, but only after I put the atlas40 on

seems like its not as bad when its warm out, I want to see if its as bad once this crap winter blend diesel is switched out.
 

·
Registered
Joined
·
192 Posts
Discussion Starter #8
Alrighty..
So, now the truck does the nice bucking action and occasionally stalls out. If it stalls I just have to turn the key all the way to the off position and then it starts right back up, as if nothing happened. It has done this 4 times now with the stalling and it bucks at 1800 RPM or so. It also surges as if it's trying to go while I'm off the pedal, at low speeds.
The Code was the ICP 2285.
I just got off the phone with the dealer and it would appear the ICP hasn't been replaced yet. So that may be the issue.
So far since August 2013 the following has been done. (under my glorious aftermarket warranty)

New Oil Cooler
New EGR Cooler
New Turbo
New IPR
New Upper and Lower control arm bushings both sides
New Outer tie rod ends (Actually I did one in a parking lot when the original broke off completely and the dealer just slapped the other on when they did the tie rods)
So far so good.. Best little warranty on the planet has saved me well over $7000 so far..

If this fixes the issue I'll report back and make a new post about it.

Thanks for any and all help up until this point. Eventually this warranty will expire (3yr 36k) and I'll be forced to do my own work again.. So I've got some time to learn as much as I can..
 
1 - 8 of 8 Posts
Top