Ford Powerstroke Diesel Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Anyone have the stereo wiring diagram ford used for cassette players in mid 90s? i removed the old stereo & have a wiring kit from crutchfield. but noticed the wires do not match in appropriate plugs (ground mating to power antenna for example). i busted out my test tool & found the switched 12v & ground, but no constant 12v. it wouldnt be hard for me to rewire the plug, but having no constant 12v is bugging me.

i do seem to have it going to the elect brake controller. so wondering how the previous owner may have rewired things.
 

·
Registered
Joined
·
204 Posts
my 97 doesnt have a constant 12v only when key turned back or running
 

·
Interior Guru
Joined
·
14,596 Posts
you should have a constant 12V to the radio.

Constant 12V
Switched 12V
Ground
4 + Speaker wires (white, green, grey, purple are the usual colors)
4 - Speaker wires
Dimmer wire

What year truck do you have? And do the plugs themselves match up?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #4 ·
you should have a constant 12V to the radio.

Constant 12V
Switched 12V
Ground
4 + Speaker wires (white, green, grey, purple are the usual colors)
4 - Speaker wires
Dimmer wire

What year truck do you have? And do the plugs themselves match up?
its a 95. it has 2 plugs; one that looks like has the power, ground, dimm, antenna, etc. then the other which looks to be the front & rear speakers. The plugs do match perfectly from crutchfield. i went online & verified the part # they sent me does match website listing for the truck. i do have power when i move the ignition to accessory or start.

my guess is someone may have snipped a wire behind the fuse panel & piggybacked on to it for the elect brake controller.

since i only use the truck to tow boat every so often, i keep telling myself not to bother w/ it. but my neurotic self keeps poking around. :tard:
 

·
Registered
Joined
·
204 Posts
Hey diggity thats exactly how mine is (97 f250) two plugs one is speakers other is power etc you will only get power when key is turned all the way back or once you turn to start my neighboors down the street is the same (or was ) way, hey re-wired it all new speaker wires gorund live etc so he can turn his on without the keys in the ignition but stock yours is right.
 

·
Interior Guru
Joined
·
14,596 Posts
If you guys are losing constant power, then you will NOT keep any programed settings. Its probably the fuse under the hood, under the dash, or KAM (Keep alive memory) fuse... Worse case scenario is, you have to run a new wire in. I know I had to in my 1982, the wires were to fragile to keep power.

Check the fuses!

Also check the wire coming in, if you got power at the fuse, and no power at the radio plug, you have a broken wire... See if you can trace it back.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top