Ford Powerstroke Diesel Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Hi my name is Matt. I have a 2002 F-250 CC Lariat, Diesel 7.3. I bought this truck used with 92K on it. I have had numerous problems with it. Though i will say it always runs and drives. Ok first things first. I had a horrible oil leak for a while and could not figure out why so much oil was in the valley. well i replaced the HPOP and that cleared up the oil leak. The steering is a major pain. I have put two new gear boxes and two power steering pumps in myself. and yet my steering is like a tractor and has a lot of play in it. i am stumped there dont really know where to go next. i have also replaced the pitman arm, ball joints, leaf spring bushings. Also my brakes pull to the left. harder i brake harder it pulls. sometimes to the right as well but 99% of the time to the left. i have torn them down and rebuilt them several times and greased all appropriate areas. I need some serious help. there is also like a clunk like the axle is moving when i am off road and i hit a rut. i am very gentle with my rig and i do very well at not being hard on it. someone please help. i cant stand something wrong with my truck. thanks Matt. i also am knowledgeable in some areas on these trucks if you have any questions or answers please feel free to e-mail me direct at [email protected]
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #2 ·
help

Is there no one on this site that can give me the least bit of help on this? I see it has been viewed several times.
 

·
Banned
Joined
·
792 Posts
As for the clunk...If you can feel it under your foot its probablt the swaybar endlinks. You can simply remove the sway bar, and if that fixes it you need new endlinks. As for the truck pulling to one side, the first thing I would say to check is the tire pressure of both your front tires, if ones softer than the other it will pull to that side.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #4 ·
sway bar

Ok i forgot to mention that i have already put new sway bar links on it. i also take my truck in and have the tires balanced at least once a month and checked and all that. but the pulling that i am having gets worse the harder i brake. also i am beginging to get quite the shake at around 70mph and up. this is a nice truck but it just does not match up to my dodge. i need serious help. i had the front end alined and i am wondering if it needs it again.
 

·
Banned
Joined
·
792 Posts
Have you tried just pulling the sway bar off alltogether? I took mine off and never looked back, I was sick of the clunking. Only thing I can think of is something in the brakes... Also check the bearings...
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #6 ·
bearings

what is the best way to check the bearings? i have jacked up the truck and the tires spin pretty well. so you took your sway bar off and no more problems? dont u need your sway bar on the truck? i do need to put new rotors on my truck though it is in dire need of those.
 

·
Banned
Joined
·
792 Posts
Well, You dont NEED your sway bar...Although performing and hiigh speed emergency avoidance maneuvers probably isnt a good idea with it off, as the truck does lean more with it...However the ride is much better, and I have much better articulation in the front now :)...You may want to put the new rotors on and see if that doesn anything...
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #9 ·
i see

will my truck still be safe for highway use without the stabilizer bar on it? i will be doing my rotors as soon as i can afford too. what do you notice is gone when you removed your sway bar?
 

·
Registered
Joined
·
305 Posts
I had a clunk in my truck a while back, i thought it was in the front end also. Well after i was hearing the clunk for awhile, i crawled under the truck to check the u-joints. I have no idea why i did, but i did. And found them to be completely gone. I replaced them and the clunk went away.
I would hear the clunk when i would hit a bump or let off the go fast pedal. I'm not saying that is your problem, but you could check it.
 

·
Banned
Joined
·
792 Posts
Only difference Ive noticed after taking the sway bar off is the body leans a bit more...You get used to it after a few minutes of driving...Ive driven on the highway plenty of times without it, I just dont suggest doing ultra fast lane changes...As you put yourself at a higher risk of tipping the truck...Go ahead and try it, it takes less than 15 minutes to take off.
 

·
Registered
Joined
·
7 Posts
My suggestion on the noise would be to check the bushings and torque settings on the track bar. If all seems well there, then check torque on all of the front end components. (including u-bolts) I would not remove the sway bar from the truck, it's there for a reason. As far as the pulling to one side when braking; make sure that your brakes are bled properly and your calipers are functioning proportionally. If you have air in one line on one side the air will compress in said line and not allow for hydraulic pressure to build causing the opposing caliper to apply greater pressure to the pads and rotor. It could also be a bad caliper. Hope this helps.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #13 ·
ok

ok one reply said check the u-joints for slack. were you talking about the axle u-joints or the rear drive shaft? I just replaced the rear drive shaft joints about a month or three ago. i am going to be doing some brake work to the truck before long i am sure that there is a colapsed line or a caliper sticking somewhere. all of you guys advice has been greatly appreciated and will be put to work. i will get to the bottom of these problems before its all said and done. i also have an issue with my 4X4 not wanting to lock in on its own i always have to lock the hubs. i put one new gasket o-ring in today and am planning on the other side soon to see if that works. does anyone have any ideas on where to look next if no luck there. thanks all of you. i will always be glad to help anyone with problems to the best of my ability and knowledge.
Matt
 

·
Banned
Joined
·
792 Posts
Do you have the manual or automatic hubs?
 
1 - 14 of 14 Posts
Top