Ford Powerstroke Diesel Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
169 Posts
Discussion Starter #1
i have tried this before, maybe better luck this time. i just need help diagnosing the problem. about a year ago the truck would start fine but run rough till warm.( would spit and sputter until 3/4 or more throttle or until warm). had it reflashed, nothing. about 6 months ago got into a front end wreck. it started stalling out of nowhere once i got it back. so they had it looked at and came to the conclusion that it was 3 injectors, cam sensor, new turbo, new up-tube(since the orginal one was cracked) and a intercooler hose had a hole in it. so the body shop had a GM mechanic put all these parts on.:doh: i know, first mistake but wasnt on my dollar. so after all those parts im not joking it is worst! it spits and sputters even when warm now, on cold start up it fights to stay idleing, and it bucks when locked up on the highway.( i know its cause the TC is locked up and im feeling the sputtering).

i know people are going to shout out ideas but i need help diagnosing, i have no codes at all no check engine light or anything.it has been reflashed a couple of months ago but not to the latest cause i found a free spartan tune for my stradegy. also when warmed up it starts up and idles fine and when reved up in park no sputtering or anything, sounds like a healthy 6.0

Im lost:dunno::dunno: :confused::confused:
any help will be greatly appriciated!!
 

·
Registered
Joined
·
169 Posts
Discussion Starter #2
:bump: :help1: :banging:
 

·
Registered
Joined
·
37 Posts
Could it be that you just have a bad computer? If you know someone that has a 6.0 maybe u could swap computers and elimanate that. I know their is a way to check them (time consuming) not sure how to though.
 

·
Registered
Joined
·
169 Posts
Discussion Starter #4
yeah i want to try that, will any 03'-07' 6.0 F-series PCM or FICM work?? i read around last night and saw alot of threads about bad FICM's and some techs were talking about how sensitive they are. i wonder if get hit at 50mph in the front is enough to fry it?
 

·
Registered
Joined
·
169 Posts
Discussion Starter #5
:bump::bump:
 

·
Registered
Joined
·
37 Posts
I have tried to do some research and couldn't find any info. I would call ur local dealer ship and they should be able to tell you in the parts department. I know the PCM is lacated on the driverside behind the battery.http://dan.prxy.org/Truck/6L_bible_html/html/Page_066.html With a front end hit it could dammaged the PCM. If your dealer doesn't give you the info i will talk to mine. I will do some checking on a way or see if you can do a test and how to on the PCM. It sounds like you have had all the other things replaced that i would have guessed. Not an expert but i know the feeling just trying to help u get started some place and not break ya!
 

·
Registered
Joined
·
169 Posts
Discussion Starter #8
that for the info 96crewcab, im not even going to try to talk to them they will just tell me they need to diagnois it and blah blah blah. if you could talk to your dealer that would be nice if you think they would tell you anything. im also thinking about re-soldering the FICM... i do automated electrical work, but never soldered on a board tho. kinda scared. oh sorry about not adding the milage. it has 110k, bought it with 80k. i usually keep it around 5k oil change rotella everytime.(cant remeber the weight, father-in-law works for shell and gives me the same weight they use in their diesel trucks.)
also i just changed the fuel filters less than 1k miles. the only thing i havnt touched on the truck is the air filter. i have taken it out when i do an oil change and never notice any wear and usually doesnt have any dirt in it when i clean it looks new.
Im with 96crewcab though, i think its the PCM or FICM i have noticed lately, when warmed up, i can give it the skinny pedal and it spits and sputters and let off and get right back on it and it wont do it....
Maybe in the morning i will get a video of cold start, cause for around the first 5 mins. it knocks like someone is driving a railroad tie. sounds like metal on metal

SORRY FOR LONG POST! dont want to leave anything out
 

·
Registered
Joined
·
169 Posts
Discussion Starter #9
aftering reading around, who has their money on the ICP sensor? thats another thing i haven't replaced.
 

·
Registered
Joined
·
37 Posts
I would agree on starting their. I Forgot about that has all the symtoms. Cheaper Easy way to see if it is bad, is pull it out and if it is full of oil or if the oil is seeping out were the plastic and metal meet on the sensor then it is no good.
 

·
Registered
Joined
·
169 Posts
Discussion Starter #11
hey 96crewcab i looked around on that website you posted and it doesnt tell you the location of the ICP sensor, i know im going to sound like a tard but i dont know where its at.(first diesel!)
 

·
Registered
Joined
·
169 Posts
Discussion Starter #12
Heres a video from this morning, it was around 30 degrees outside. i know its not that bad i just dont like the idleing up and down and the metal on metal slapping. hope the video helps.
http://www.youtube.com/watch?v=XEZIQYHYD3o
 

·
Registered
Joined
·
37 Posts
Here is a link to pics. http://www.powerstroke.org/forum/6-0l-problems-forum/39331-icp-sensor-issues.html Here are some more http://www.atsdiesel.com/PDF/ICP-Sensor-Ford-6.0L.pdf Some people say to go from the bottom and some say the top. I went from the top. Pulled the intake out of the way and took the coolant reasavor off. When you pull the 3 wire plug off and oil comes out it tells you that it is bad. On my dads pickup it was leaking oil onto the tranny and running down. I used a 1-1/16 12 point deep well socket, but had to cut some of the socket off to make it fit with a swivel on it. It takes some time.
 

·
Registered
Joined
·
169 Posts
Discussion Starter #14
damn im getting frustrated with the dang thing, it sad that these 6.0's can pass up everything but a parts house or dealership!! my wifes grand prix is running circles around this thing.:sad:
Maybe the goverment will bail out the 6.0's?? they had to bail out everyone else.:dunno:
HEYYY!!!! maybe they will recall the 6.0 and put in 6.4 or 6.7???????:hehe:
 

·
Registered
Joined
·
37 Posts
lol i hear ya! The biggest problem is trying to find the problem! Still trying to figure my out.
 

·
Registered
Joined
·
169 Posts
Discussion Starter #16
oh yeah, you found that shaking problem yet?? and i think im about to bite the bullet and take it to the stealer ship.im an electrical guy not too much mechanical. which ive done my fair share of mechanical but i just dont like to.
i think the least ford could do is give all the 6.0 owners a scan tool for all the damn headaches and the ones to come. no??
 

·
Registered
Joined
·
169 Posts
Discussion Starter #17
:bump::bump:
 

·
Registered
Joined
·
37 Posts
I think i found the problem my spline in the drive shaft is wore. Taking it to a drive shaft shop next week to get fixed and balanced. The 6.0 don't have to many problems, but it just seems like when they do get a problem they r just hard to find! I dont think changing the sensor is not that big of a deal just in a tight spot.
 

·
Registered
Joined
·
169 Posts
Discussion Starter #19
Yeah i read up on it i think i can handle it, just when i thought i was getting my problem narrowed down until today. :( did you see my other thread puking coolant?
well congrats on finding the problem hope thats your fix!
 
1 - 20 of 21 Posts
Top