Ford Powerstroke Diesel Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
This happens when I start my truck up - here are some other items

1) sometimes the door open light is on while truck is running & all the doors really are shut. The dome light stays on.:dunno:

2) turn the truck off - leave the key in ignition,exit truck, close the door & the dinger keeps dingin:dunno:

The dealer put in a new fuse box. & also a module - I'll have to look for the part # but my real issue started out that my blinkers didn't work unless I stuck a pencil between two of them but that got old after 2 years so the replaced it & dealer said it was rusted in the back when they replaced it. after it was fixed I tried my remote button to unlock the truck - its didn't work. They took the fuse box back out & said it had water in it. (leaking windshield drivers corner) I never saw water on the floor or anywhere else.
 

·
Premium Member
Joined
·
11,881 Posts
This happens when I start my truck up - here are some other items

1) sometimes the door open light is on while truck is running & all the doors really are shut. The dome light stays on.:dunno:

2) turn the truck off - leave the key in ignition,exit truck, close the door & the dinger keeps dingin:dunno:

The dealer put in a new fuse box. & also a module - I'll have to look for the part # but my real issue started out that my blinkers didn't work unless I stuck a pencil between two of them but that got old after 2 years so the replaced it & dealer said it was rusted in the back when they replaced it. after it was fixed I tried my remote button to unlock the truck - its didn't work. They took the fuse box back out & said it had water in it. (leaking windshield drivers corner) I never saw water on the floor or anywhere else.
Your speedo problem and OD light flashing cold be caused by a speed sensor in the rear differential. You could try and pull codes and see what comes up. The dome light staying on is caused by a switch in one of your doors. There is a switch in every door and it is built into the latch. Get some contact cleaner and spray in all of the latches. Open and close all the doors multiple times and see if the lights go out. Hope this helps.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
OK I'll try the door thing.
as far as the od & speedometer - sometimes is works & other times not. The good thing on the not is it will have fewer miles:crazy:

On a side note I just power washed my engine & I'm looking for leaks. I think the two lines (hpop thing?) might be leaking. I'm afraid to bring it back to the dealer because they never said anything about testing my diesel for leaks. I'm only gettin 13.5 around town. 8.5 pulling the toyhauler:doh:
 

·
Premium Member
Joined
·
11,881 Posts
OK I'll try the door thing.
as far as the od & speedometer - sometimes is works & other times not. The good thing on the not is it will have fewer miles:crazy:

On a side note I just power washed my engine & I'm looking for leaks. I think the two lines (hpop thing?) might be leaking. I'm afraid to bring it back to the dealer because they never said anything about testing my diesel for leaks. I'm only gettin 13.5 around town. 8.5 pulling the toyhauler:doh:
Probably just o-rings causing the leak. It could still be the rear speed sensor. I would still check for codes.
 

·
Premium Member
Joined
·
9,390 Posts
Your speedo problem and OD light flashing cold be caused by a speed sensor in the rear differential. You could try and pull codes and see what comes up. The dome light staying on is caused by a switch in one of your doors. There is a switch in every door and it is built into the latch. Get some contact cleaner and spray in all of the latches. Open and close all the doors multiple times and see if the lights go out. Hope this helps.
ditto:thumb:
 

·
Registered
Joined
·
17 Posts
Discussion Starter #6
By testing for leaks - if there are any - assuming there was & they got fixed. Would that increase my mileage? OK I talked w/ a friend about my truck. It must be leaking on the top because the bell housing has oil over it. I looked & think the oil is coming from the cover that has the two orange hose fitting going to it. (just below the turbo?)

The next is the oil is on the drivers side cross member but it must be the pan .

Man this sucks. Its going into the dealer to be checked. If the motor has to come out then I gotta see how much & if I can afford it. The leak on top - maybe they should wait if the motor comes out & do it all at once? Wish me luck. Its going in on wednesday.
 

·
Premium Member
Joined
·
11,881 Posts
By testing for leaks - if there are any - assuming there was & they got fixed. Would that increase my mileage? OK I talked w/ a friend about my truck. It must be leaking on the top because the bell housing has oil over it. I looked & think the oil is coming from the cover that has the two orange hose fitting going to it. (just below the turbo?)

The next is the oil is on the drivers side cross member but it must be the pan .

Man this sucks. Its going into the dealer to be checked. If the motor has to come out then I gotta see how much & if I can afford it. The leak on top - maybe they should wait if the motor comes out & do it all at once? Wish me luck. Its going in on wednesday.
Probably high pressure oil line fittings causing the entire problem. You don't see a lot of oil pan gaskets leaking on the 7.3 trucks.
 

·
Registered
Joined
·
6,168 Posts
Relax... Its not your pan, the motor doesnt have to come out... The oil in the valley could be HPO O rings, IPR, ICP sensor or turbo pedistal O rings... Nothing to get excited about. Clean it up good with degreaser and drive for a day. Then feel around and find exactly where its leaking.

Also, look up the CCV mod and do it. Your orange boots are covered in oil because of the ccv oil, its soaking thru them.
 

·
Registered
Joined
·
444 Posts
My door ajar light did the same thing and my dome and cargo light would stay on. Sprayed some silicone spray in each door lock and it has stopped the problem for a year now with it not happening again to this day.

I had a hell of an oil leak myslef up in the valley. I took it to a shop and they said rear main and that's what i thought too. I found my way to this website and diagnosed it to be the hpop orings with the help of the guys on here. ( Thanks again Scuffy) I replaced the orings and bang it hasnt leaked a drop since. just turned 200 thousand and running great with no leaks or door lights coming on.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #10
OK - its in the shop, lets see what they come up with. I'll share as soon as I know. When I dropped it off they had someone else's truck w/ the motor out because they where getting a new oil pan.

Whats the cost at a dealer VS. private shop to do the oil pan thing?
Ford has is around $2000 - $2500. & as high as $3000 if you need up pipes.

I'm in North Western Jersey.

My thoughts are that they are trained & have the tools to do the job. No matter what its hard to find someone that you trust & don't cost an arm & a leg.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #11 (Edited)
Let the PARTY & GAMES begin

I'm so happy. Today is Thursday. I started my day w/ a shower:thumb: , Called about my truck & they said come get:clap: It turns out my leaking oil was the cam shaft sensor. They replaced it. Next I mentioned the epb sensor tube - it was clogged - replaced that. Next my AC wasn't working - charged it - Good to go:woot: Never been so happy about spending $575.00:doh: Anyway getting ready to load the toyhauler up (4 quads & a dirt bike) & our couch for the annual couch race (got 3rd last year) Its gonna be fun. I would like to say thanx for posting & the words of wisdom "RELAX":)
Check out atvriders.com or Breezewood motorcross park.com - u tube it & I'm sure someone will post the race.:icon_ford:
 
1 - 11 of 11 Posts
Top