Ford Powerstroke Diesel Forum banner
1 - 9 of 9 Posts

·
Premium Member
Joined
·
310 Posts
Discussion Starter · #1 · (Edited)
Ok is it just me? I ordered 2 Spartan Diesel tuners for the 6.7L Ford based on them telling me they all ready have EGR Delete files installed. I ship them to my customer who install them in a 6.7L Ford and is now having EGR codes. Phone tech support get grief, was told I need to order a specific EGR Delete kit from some "Street Performance" company that no one has ever heard of. When asked why this information was not given to me at time of purchase or listed on their website I was hung up on, so I called back and was hung up on again... This is how they treat their dealers can you imagine how they treat their end users.... I was a dealer? This is the second time this week they have delivered such great service.

Great service guys! This is why I stock the H&S Mini Maxx

Tell us how your support with Spartan has been?
 

·
Registered
Joined
·
331 Posts
I've had spartan with both my 6.4 and 6.7. No issue with tech support either time. Anything I needed they were quickly able to solve my problem. The company you are looking for is Street Diesel Performance in CT. The owner's name is Sean.

The tuner should work with any egr block off plates. You shouldn't be getting codes regardless as the tuner turns off the EGR. The only way you would be getting codes is if the end user installed the wrong tune or didn't follow the instructions.

That being said, it's pretty unprofessional of a DEALER to come on a forum and bash a company. You are a grown adult serving a large diesel community. If you have a problem with a company, bring it up with them. If that doesn't work, discontinue selling their products in your store.
 

·
Premium Member
Joined
·
17,841 Posts
There isn't any bashing that I'm seeing.......Dave simply pointed out facts and wants answers. Part of the reason this forum exists, gives the consumer more of a chance to be heard......now we will wait for Spartan's response
 

·
Premium Member
Joined
·
310 Posts
Discussion Starter · #5 ·
Unprofessional, I was the one hung up on twice... who does that?

All I wanted was some help, not attitude and to not be hung up on because they did not have the answers. I was respectful and was not even upset just wanted to help my customer, who also was getting no help when he called in.

I do not have the products on the shelf anymore and have requested I be taken off the dealer list. All the Spartans have all been replaced with the H&S Mini Maxx because they work and I do not require contacting a third party company to get them working, plug the Mini Maxx in, program it in 5 minutes not 40 minutes and most importantly they work right out of the box.

Dave
 

·
Premium Member
Joined
·
310 Posts
Discussion Starter · #6 ·
I still need to get the customer fixed up and am still unclear what he needs. I tried to contact Street Performance but they are one of those shops that do not provide a contact number so am waiting for an e-mail reply.... so the run-around continues. I will post how long it takes to get an e-mail response.

I found this EGR Delete Kit on the Street Diesel Performance site but am not sure if it is what is needed as no one is there to confirm and it looks just like the H&S EGR Delete kit the customer has already installed so am hesitant to order it without confirmation that it is the fix, then ship it to mu customer only to find out it is not the fix.

I notice he has the H&S Mini Maxx is listed on Street Diesel Performance's site but not sure I seen the Spartan?

Dave
 

·
Premium Member
Joined
·
8,814 Posts
Dave,

I'm looking into the situation. We will get this sorted out. I will also see if I can get you in contact with Sean at Street Diesel Performance.

Thanks,

Jeff
 

·
Premium Member
Joined
·
310 Posts
Discussion Starter · #8 ·
Thanks for posting Jeff,

Sean was quick to get back to me and has this for us to try.

"Sounds like you just need our spartan coolant tube kit which sells for 129, and then read our instructions to pull the throttle valve back in that h and a had you unplug. That should fix you up."

I will keep you posted, hopefully this is the fix and we can get this up on the Spartan site to assist others in the same situation.

Dave
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top