Ford Powerstroke Diesel Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
735 Posts
Discussion Starter #1
Nobody is responding to me in the problems thread, so please someone help. I am trying to get my engine back together and above the cam I found what appears to be a broken something or other. is this normal??

 

·
Premium Member
Joined
·
22,934 Posts
I don't know much about all the workings of a 7.3 but I will pas this onto a buddy of mine who does.
 

·
Registered
Joined
·
3,098 Posts
I watched a video on Powerstroke Help where he shows the back of the motor, and it appears that is open like that, but it doesn't look normal too me.

Maybe someone will post up a better answer than mine:dunno:
 

·
Don't you worry about it
Joined
·
8,335 Posts
I found this on another forum "that is the passage that supplies oil to the resiviour for thehigh pressure oil pump. you are fine. make sure the pipe plug to the right of the cam bearing is tight if it comes out you will not start cause you will get no oil to your high pressure pump."
 

·
Premium Member
Joined
·
22,934 Posts
Linky no worky Keith...
 

·
Don't you worry about it
Joined
·
8,335 Posts
Yea I guess because it's another forum it blocked it out.
 

·
Don't you worry about it
Joined
·
8,335 Posts
every pic on google has the hole but most seem to look a little less like someone busted it out with a screwdriver lol
 
  • Like
Reactions: Heavy_GD

·
Registered
Joined
·
735 Posts
Discussion Starter #9
Ok thanks everyone!!! I just installed the new dipstick flange... I don't remember what position it was at as far as the notches go. I looked at some pictures on google and it seemed the flange was more at a 3 o clock rather then 1 o clock. Am I right? Thanks a bunch I was beginning to think everyone migrated to another forum or something
 
1 - 10 of 10 Posts
Top