Ford Powerstroke Diesel Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
746 Posts
Discussion Starter · #1 ·
hey guys i could really use some help.

My 2000 7.3 had a miss in the engine that was pretty suttle for a long time but it started to get worse and i would loose power taking off of lights sometimes. So i took it to the local diesel shop. there really good friends of mine and wouldnt try to screw me. but so taking it to them they took a while to find the problem since there was no SES light on. but they determined that the ICP and i think its called the IPR were bad so we replaced them. the truck will not start at all anymore. they said the HPOP is bad now. the truck never ran after the two sensors so i dont see how the HPOP could just go out like that.... really frustrated and i need my truck back so any help would be greatly appreciated..
thanks
 

·
Premium Member
Joined
·
11,175 Posts

·
Registered
Joined
·
746 Posts
Discussion Starter · #3 ·
My truck is still at the shop.

There is one code that relates to this problem i dont remember what it is but its why we repplaced the sensors.

we replaced the IPR on the truck. after that it would only crank. so they popped the top of the hpop to see if it needed oil and to add any but im not sure what they found or did there. ( i had to leave at this point)

and all the wires are good i think. but that can be double checked just to make sure.

We also unplugged both my chips
 

·
Registered
Joined
·
54 Posts
Whats your ICP while cranking?

Whats your IPR duty cycle while cranking?

Batt voltage?

Cranking RPM?

Kinda sounds like the IPR is stuck open, hard to say without some numbers first.
 

·
Premium Member
Joined
·
11,175 Posts
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top