Ford Powerstroke Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter #1
Just got in the truck and it was cranking really slow, never cranked like this... Stop, reset, and cranked again, still very slow, then started all of a sudden... Thoughts? No mods. Original glow plugs.
 

·
Premium Member
Joined
·
2,623 Posts
Weak batteries or worn out starter.
 

·
Registered
Joined
·
76 Posts
Discussion Starter #3
Batteries it was! Replaced both and fired right up. Old ones measured 9.36V... deader than dead.
 

·
Registered
Joined
·
56 Posts
I thought my batteries were dead too, even had them tested. Put new ones on and it started good for about a month and then they were dead. Turned out to be a bad alternator, but the new batteries still lasted a month before dying on me. Either my old alternator was putting out a little bit of charge, or these trucks don't use much juice after starting.
 

·
Registered
Joined
·
76 Posts
Discussion Starter #5
so i did the poor man's alternator test after i put the new batteries in and it said 13.9 or 14.1 i think. so that means the alternator is good, right? i'd love to do the dual alternator install but seems really expensive and time consuming... most people say to just rebuild the existing alternator to a higher output.
 

·
Registered
Joined
·
585 Posts
That is within spec, you’re fine. Absolutely no reason to run dual alternators unless you have a sound system straight out of SEMA


Sent from my iPhone using Tapatalk
 
1 - 6 of 6 Posts
Top