Ford Powerstroke Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,203 Posts
Discussion Starter #1
so yesterday i was on my way to my dads to pick some stuff up and noticed when sitting at a light the engine has a slight surge not constant but evey so often it would jump maybe 50-150 rpms and would even make the truck roll forward a little depending how much pressure i had on the brakes. it has been doing that for a little bit now maybe 2 weeks but yesterday was the first i noticed when coming to a stop about 5-10 sec after complete stop it would start studdering a little not enough to say it was a misfire but enough to know it was there. about 3 weeks ago on my way to the dump i noticed in about 3rd gear around 2800-3000 rpms at maybe 1/2 throttle i would get a slight mis only did it the one time so didn't think much of it but now with this happening not sure if it is related. i mentioned it to a friend that is a ford tech and said something about being a injector mis. all injectors probably only have about 40-45k miles.

any ideas from you guys. hope im not having injector problems. don't have that kind of money. but if it is then im not putting factory back in it.
 

·
Premium Member
Joined
·
2,056 Posts
sounds like you should take a look at icp readings it may be starting to go.
 
Joined
·
1,023 Posts
doesnt sound like an injector-you may have a high pressure oil leak developing, i ran into this problem with picky customers and found stand pipe orings worn, dummy plug o rings worn, stc fittings (depending on year), and ICP sensors weeping oil, IPR screens being clogged, or mechanical failure of the IPR itself. Ive road tested and found this by holding them wide open quite a bit and notice a buck/skip monitor ICP IPR FICM MPWR because a ficm on its way out ive found causes a buck/skip while under load as the voltage drops. Monitor those pids and see the IPR commanding and going to 84.99% and the ICP fall down then spike up level off and spike up again.

If you see any oil purged through the ICP sensor and on the harness-replace them both. You can remove them without pulling the turbo and intake. I do all the time.
 

·
Registered
Joined
·
1,203 Posts
Discussion Starter #4
I was thinking icp I've had that go bad before causing the surge at idle but not the studdering. Can a bad icp cause the studdering too? Ficm was replaced back in November also has new hpop.
 

·
Registered
Joined
·
382 Posts
I had the surging problem on mine and while it was doing it in the driveway I played with the plugs going to the FICM and that cleared it right up. Not sure if one was loose or if its a bad connector but you might want to start there, The pigtails can be replaced if needed.
 

·
Registered
Joined
·
1,203 Posts
Discussion Starter #6
ill try it out thanks any more input about the icp possibly causing the problem?
 
1 - 6 of 6 Posts
Top