Ford Powerstroke Diesel Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
143 Posts
Discussion Starter · #1 ·
So I have an 04 f250 6.0 PSD with a SCT X3 Custom tune from Innovative Diesel. I installed the Edge Insight for a monitor and the Insight doesn't allow me to select Ford Specific PIDs from it's setup display. I talked to edge and they re-flashed my Insight. Still had the same problems. They sent me a new Insight with but i continue to have the same problems. They don't know what it is. I asked 4 different techs when i called in if the SCT Custom tune would cause any problems and they all said no. so just for the heck of it I returned my tune to stock and now the Insight shows Ford specific PIDS and works as normal.

I'm sure there are other people out there that have a SCT custom tune and an Edge insight? Just wondering if anyone has had the same problems or any insight (ehhhh) as to what the problem may be.
 

·
Registered
Joined
·
143 Posts
Discussion Starter · #2 ·
kinda figured

So I talked to Edge and they said that i must be the programmer since it works when the program is returned to stock. kinda figured they'd say something like that now...even though the first four techs it shouldn't.

Talked to Innovative diesel and they confirmed that they have hundreds of setups that are running an SCT custom tune and an Insight. They have never seen this issue before. I tried another custom tune (Extreme Street instead of Street) to see if it was something wrong with the specific tune...still no luck on getting Insight to display Ford Specific PIDs in the setup.

Any ideas....
I'm still working with IDP and Edge too trying to figure this out.
 

·
Registered
Joined
·
6 Posts
My reply on another thread

#48 (permalink) Today, 12:31 AM
snowboat
Powerstroke.org Rookie
snowboats Gallery Hall

Join Date: Nov 2009
Posts: 1

A solution is coming

--------------------------------------------------------------------------------

I too bought parts from IDP and had trouble with Chrysler PID's showing up on my 2004's tune. After numerous call's to IDP. SCT, and Insight it has come to this. All three companies say it isn't really on their end. They were all very polite and had suggestions. Jason, a tech at Insight did go to his engineers and they said they will look at the problem, and most likely fix it in the first week of December, or by the end of the year. They are in the middle of a new release and will get to that problem next. Jason asked that I be patient and I am looking forward to their repair.
 

·
Registered
Joined
·
896 Posts
Wow...this sucks.

I'm a new SCT user, only have the Pre-programmed Performance tune loaded, but just picked up an Edge Insight that I will use as my gauge..with the EGT probe. Will I run into the same problem with the canned tune or is it just a custom tune issue. I hope they fix this, because I plan to run IDP's Extreme Street and Tow when I get ready for my EGR delete. :dunno:
 

·
Registered
Joined
·
3,352 Posts
So I have an 04 f250 6.0 PSD with a SCT X3 Custom tune from Innovative Diesel. I installed the Edge Insight for a monitor and the Insight doesn't allow me to select Ford Specific PIDs from it's setup display. I talked to edge and they re-flashed my Insight. Still had the same problems. They sent me a new Insight with but i continue to have the same problems. They don't know what it is. I asked 4 different techs when i called in if the SCT Custom tune would cause any problems and they all said no. so just for the heck of it I returned my tune to stock and now the Insight shows Ford specific PIDS and works as normal.

I'm sure there are other people out there that have a SCT custom tune and an Edge insight? Just wondering if anyone has had the same problems or any insight (ehhhh) as to what the problem may be.

here is a temporary fix that should hold you over until edge gets the new flash out

I went through this a while back, drove me insane...here's what works for me:

After putting your tune in..or any time you unhook the Insight:

Key Off, Plug in Insight
(Vin Not Found) Press Enter
(Detecting Vehicle)Choose Ford
(Choose Type)Choose Diesel
(Error Can Communications) Or something like that

Key On
Press Enter You'll get another Can Error
Press Enter again and everything will be happy.

This is paraphrasing of course, but it'll get you in the right direction..I was gonna write it down while I was out in my truck coming up with the sequence for you, but it's freakin cold out!
 

·
Registered
Joined
·
896 Posts
So, I finally got the Insight hooked up...I currently have the Performance tune (pre-programmed SCT Tune) loaded. I hooked up the Insight and it asked for Gas or Diesel...no Make specific (i.e. Ford)....then the display came up with EGT N/A (becausae I don't have the probe installed yet), Trans Temp, Trans Slip, RPMs, Speed, ECT, Boost, Throttle Position Pedal, I guess there are more...just haven't opened her up yet and loaded any software to set parameters and see which other PIDs are available. I thought I would see Ford specific from the beginning, but maybe I have some tweaking to do. More to follow.:thumb:
 

·
Registered
Joined
·
143 Posts
Discussion Starter · #7 ·

·
Registered
Joined
·
896 Posts
fordstang93....yeah, I been watching that blog too. I ran my Insight on the way in to work this morning (26 miles stop and go, not towing)...Of the three PIDs I had up...here's what I got (ECT=190'F), (TransTemp=158'F), and (Boost-mirrored the OEM analogue).
 

·
Registered
Joined
·
896 Posts
Just an update...got to fiddlen' around with the Insight some more...I now have the following PIDs running...Mod Volts, EGT, Diesel EOT, ECT, Trans Temp, and IAT 2...I could have chose many others, but these are the ones for now...So all this while using my new SF3 with Pre-programmed Performance Tune. Gotta Love it...:thumb:
 

·
Registered
Joined
·
523 Posts
You guys that are gettin' ect and eot readings just have the original Insight correct? Not the newer CS or CTS? Am I picking up on this correctly that the Insight needs to be or can be updated to read eots? The manual isn't very clear to me how to set all the displays or view parameters:crazy:.

Please help, much appreciated :thumb:
 

·
Registered
Joined
·
896 Posts
You guys that are gettin' ect and eot readings just have the original Insight correct? Not the newer CS or CTS? Am I picking up on this correctly that the Insight needs to be or can be updated to read eots? The manual isn't very clear to me how to set all the displays or view parameters:crazy:.

Please help, much appreciated :thumb:
Wow...this is a blast from the past....almost a year to the day. Yes, we were referring to the original Insight...not the CS CST models. EOT is displayed as Diesel EOT.
 

·
Registered
Joined
·
523 Posts
Oh hey I see that now. lol Heck I was just lookin at the month and date. :doh: Well anyways I just got mine today and haven't had much time to tool around with it yet. I've been diggin most of the evening but I'm gettin thrown off since posters aren't being clear which model insight they have so I'm still scratchin my head on how to retrieve the engine oil temp on my 2004. I suppose I could try the vin entry like some suggest or try to figure out which gauge display to select in the menu.
 

·
Registered
Joined
·
523 Posts
Doh, figured out where to find eot in the display menu and how to arrange it all. This thing is pretty damn cool once I learned how to use it.

Thanks
 
1 - 13 of 13 Posts
Top