Ford Powerstroke Diesel Forum banner

1 - 20 of 29 Posts

·
Registered
Joined
·
146 Posts
Discussion Starter #1
So I just installed all 8 injectors now the truck wont start and is throwing low circuit codes for 6 injectors? Comes up to oil pressure but doesnt even try to start? Also threw a Low ICP code:(
 

·
Premium Member
Joined
·
5,700 Posts
The low ICP code is from having the oil rails off. It's going to take a minute or 2 of cranking to get ICP built up enough to fire.

Injector circuit codes can be caused by a failing ficm. why were you changing the injectors to begin with? Make sure the FICM harness plugs are fully seated
 

·
Registered
Joined
·
146 Posts
Discussion Starter #3
The FICM is reading 48v so i figured thats good? The injectors were changed because it felt like i had a bad spool valve on one, Would feel like driving on a gravel road
 

·
Registered
Joined
·
146 Posts
Discussion Starter #4
ICP reads 0.4 when trying to start and doesnt move?
 

·
Registered
Joined
·
146 Posts
Discussion Starter #5
Oil pressure goes up after cranking a second and holds untill i stop cranking then a second later drops off as well
 

·
Premium Member
Joined
·
5,700 Posts
ICP should go up to around .7 or .8 before it will fire

did anything happen going back together that was questionable? standpipes line up okay? the 04s can be a pain in the butt sometimes
 

·
Registered
Joined
·
146 Posts
Discussion Starter #7
I did put the udpated stand pipes in? Seemed to go together ok oiled them and put them in torqued down to 60lbs? I put updated dummy plugs in as weel
 

·
Registered
Joined
·
146 Posts
Discussion Starter #8
I put the longer piece in first,had to tap top piece in to get it to start threading. That was on both sides
 

·
Premium Member
Joined
·
5,700 Posts
yeah that sounds normal. the longer piece sits down in the branch tube and needs some pushing to get it started
 

·
Registered
Joined
·
146 Posts
Discussion Starter #10
i dont know what to do
 

·
Registered
Joined
·
146 Posts
Discussion Starter #11
I got it to fire!!! Just now it sounds like its running on 7 cylinders???
 

·
Registered
Joined
·
146 Posts
Discussion Starter #12 (Edited)
So the ficm plug was a bit loose. Now it runs but it smokes and sounds like it has a bad miss which is similar to what it was doing before other than the smoking?

I thought I was capable of doing this repair,I guess not. I took my time and torqued everything to spec
 

·
Registered
Joined
·
146 Posts
Discussion Starter #13
If I let the truck sit a minute it takes forever to start again...Then it smokes and feels like its running on 7 cylinders
 

·
Registered
Joined
·
146 Posts
Discussion Starter #14
The Whole story

Ok about a month ago my truck started to get a little bit of a miss and then it got worse as in would feel like traveling on a gravel road every once in a while.

So I ordered all 8 new 155/stock from warren diesel and put them in yesterday and today also decided to do updated stand pipes and dummy plugs while I was doing it.

Got it all back together and the truck takes forever to fire,ICP stays at 0.3-0.4 for a while and takes a good 10-15 seconds before it will start. The Fuel PSI builds up to 64 psi while starting but has little to none with just the key on:dunno:

Then it will start but when running it runs like its on 7 cylinders and smokes,Never smoked before but did have a miss. Also is now not throwing any codes.

Just looking for any suggestions? I'm at a loss

The new stand pipes not building pressure to start? I cant believe so many have things have gone wrong
 

·
Premium Member
Joined
·
5,700 Posts
I know, it can be difficult sometimes to troubleshoot these things on your own. I replied to your PM
 

·
Registered
Joined
·
146 Posts
Discussion Starter #16

·
Registered
Joined
·
146 Posts
Discussion Starter #17
Ok just to update this it looks like received a faulty injector so they are sending one over night and hopefully that fixes the issue. I checked all the wiring today and everything looks good
 

·
Registered
Joined
·
146 Posts
Discussion Starter #18
Got the new Injector installed tonight and all is well again. Thanks to all for the Help especially Sinner 6.0l for the PM help
 

·
Registered
Joined
·
146 Posts
Discussion Starter #20
1 - 20 of 29 Posts
Top