Ford Powerstroke Diesel Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello all,

I have an 05 Ford F350 that I am beginning to have issues with. I recently drove the truck To Tennessee from Texas to pick up my 14000lb fifth wheel and bring it back to Texas. The truck drove wonderful and performed flawlessly.

After towing the fifth wheel a couple of more times I noticed I was getting a wrench light that would delete itself after I killed the truck, passed this off as my deltas were bad due to oil cooler or EGR cooler.

When I arrived home I popped the hood and noticed that the radiator was cracked on the upper tank as well. I ordered a new radiator, oil cooler, and EGR delete from Rudys Diesel Performance (I had good luck with this place with my other 07 6.0) and broke the engine down and replaced the parts. I did not install a tune as this truck is used solely to pull the fifth wheel. EGR valve and cooler were removed completely, but no CEL is on.

No more wrench light, success. I began to notice coolant on the driveway after the truck would sit for a day or so, and it appeared to be coming off of the valley. So, from my past experience I figured it was coming from the crappy blue hose that is sent out with the EGR delete kits. I didn't want to tear down the top of the engine again (turbo, intake, etc) in order to install the OEM hose, so i loosened it and re adjusted the clamps. It seemed to slow down the leak substantially, but not completely.

I hooked up to the fifth wheel and took off for Indiana from Texas and about 4 hours into my trip I noticed that the dummy gauges were heating up to about 3/4 of the way, but if i backed off the throttle (from 65mph to 50) it would go back down to normal for about another 120 miles, then repeat the process. The whole 25 hour trip was done this way, adding distilled water (about 4 gallons total) throughout the trip.

I would like to know what you guys believe is going on. With the EGR being unplugged, but the truck not being tuned is my fan working at 100%?

There is no puking from the degas bottle. I have 2 weeks to figure this out, then I am off to california.

It is probably best to state that the truck does not act up at all without the trailer. I could hop in it and drive all the way back to texas without the truck running warm.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
But 4 gallons to work out air in the system seems crazy to me. Also, The fan comes on so I know its not unplugged. I just dont know if it is hitting the RPMs that is necessary to cool this engine.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
I did think about the thermostat going bad, but in my opinion the Thermostat will go bad, or it wont. Its not going to toy around and open and close and open and close itself. It wont run hot again now that the trailer is not hooked up.
 
1 - 3 of 3 Posts
Top