Ford Powerstroke Diesel Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I drive an '04 Excursion 4x4...stopped yesterday to get $30 in diesel, on way to football game, truck was running fine. After refueling, tuck started back up just fine and I drove about 3/4 of a mile to destination, where truck sat for about 3 hours.

When I tried to start up after the game, the truck would turn over, maybe hit (just barely), but wouldn't start. After a couple of tries, it hit just enough to start, but ran VERY rough about 4 seconds before shutting off again. At this point, I wondered if there was water in the diesel I had added earlier, and I looked down and noticed the Fuel in Water light was on when I turned the switch on (I didn't notice if it was on earlier). So, I drained about 1/2 cup of fuel from the Fuel/water seperator on the frame under the truck...to the point where the fuel looked good.

I tried to crank but at this point it just turns over and doesn't seem to hit at all. I cycled the switch on and off about 10-15 times, per Ford dealer mechanic instructions (phone) and tried it, but it still wouldn't hit. I thought I noticed a small hit once, maybe twice, but may have been hearing what I wanted to.

Now I'm stuck and looking for guidance and have been wondering about the following:

1. whether I got water into the cylinders,
2. maybe didn't drain enough fuel (didn't get all water out), or
3. whether I have good fuel but didn't cycled the switch enough to make up
for the fuel I drained out...

I just don't know where to go next.

This is the truck I work with, so any suggestions to get me going would be greatly appreciated!! :dunno:
 

·
Registered
Joined
·
1,509 Posts
It could be hydro locked because of water in the cylinders but that doesn't seem probably to me. $30 in diesel could never have enough water to fill your separator that fast and be injected into the engine. Take off the filter cap on the top of the engine and make sure theirs fuel in it and it looks clean. If there isn't any fuel then your pump could be bad. If their is fuel then it could be a FICM problem. FICM problems are very common on the 6.0. If you need help on how to check the FICM email me:
[email protected]

Also, if you have a scanner or tuner than scans the PCM see if you threw any codes.
 

·
Registered
Joined
·
1,621 Posts
maybe losen the filter cab just a smidge and cycle the key to finish filling with fuel if its not full.
 

·
Registered
Joined
·
65 Posts
Well...

1. It's def. not hydro locked if it's turning over. It means just that, lock, it would either stop turning dead in its tracks or bend a rod. In which case you would know.

2. You drained enough fuel, in my opinion anyway.

3. Cycling the key and turning over two or three times should purge this.

I think there is some other issue since it wouldn't start before you did anything to it.

HPOP maybe. As suggested any codes will help make diagnostics faster.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top