Ford Powerstroke Diesel Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,107 Posts
Discussion Starter #1
Ok new problem, I get a rpm surge while driving at just off idle, Not all the time every now and then. Seams to be more noticeable the first mile after start up then gets better. No CEL no tranny slipping(truck accelerates with rpm surge) fuel filter has only 1000 miles on it, but I'm running WVO 50/50 mix. I'm had filter clog before and this isn't acting like that. Any ideas?
 

·
Registered
Joined
·
659 Posts
what rpm does it do it at and does it do it when it is in park and you slowly rev it
 

·
Registered
Joined
·
1,107 Posts
Discussion Starter #3
It happens just above idle, I's say around 900-1000 rpms. Never noticed it in park. It acts just like you hit a bump on a rough road and blip the pedal.
 

·
Registered
Joined
·
659 Posts
i have seen a lot of powerstrokes do just what you say when the orings on the ipr valve need replaced. it will almost never throw a code though.i would get the codes pulled and if there are none you might just swap out those orings and see what happens.it has worked many times on other 7.3 and cat motors as well.easy to do and cheap.
 

·
Registered
Joined
·
1,107 Posts
Discussion Starter #5

·
Registered
Joined
·
659 Posts
yea that is the one.
 

·
Registered
Joined
·
659 Posts
you can also get it at ford for about 40.00 or 50.00 bucks
 

·
Registered
Joined
·
1,107 Posts
Discussion Starter #8
Thanks I'll give that a shot, I just had an high pressure oil rail o-ring fail so it looks like all the rubber is getting old.
 
1 - 8 of 8 Posts
Top