Ford Powerstroke Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
I have a 07 6.0 that has 153k on it and of course with the cooler temps the truck has a very rough start up. Temp was about 28 degrees that night and she spit and sputtered for about 45 seconds and Once warm she starts and runs like a beauty! She has a performance tune on it with the X4 from previous owner and lift pump. I changed the oil recently and did the arch oil additive to help with any stiction. Problem still persists on cold starts. Batteries were from 2018 so I went ahead and replaced them. From what my 6.0 friends are telling me it sounds like injector(s). Should I go ahead and plan to do all or just ones that may have issues? It does have a slight miss at warm up but goes away. Any tips would help, thanks!
 

·
Registered
Joined
·
98 Posts
Injectors are expensive. Don’t change any of them unless you know that they are faulty. Your x4 will give you most fault codes needed to diagnose. I know because I have one and it has helped me through 90% of my problems.
 

·
Registered
Joined
·
2 Posts
Having same issue my truck was running great then it started running rough. Pulled my fifth wheel home. Turbo was up to 25,the pyrometer gauge was acting up so i could not get the temps. Could not go past 70 mph. No smoke or codes. Dealership just installed this high pressure oil pump an couple months ago . Any thoughts
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
It DOES have a Cyl #6 open circuit. Previous owner said he put glow plug in and light didnt go out so he said it needed a Glow plug module. I put a module in it and still shows open circuit on #6. So i assume he didnt put a glow plug in it :| I got a glow plug and harness in case it breaks during removal just havent had the time to put it in. The reason I/we felt injectors is bc of the 10.5 mpg i am getting also. The current tune is in performance but I am not in the throttle AT ALL. I baby it for the most part so the very low mpg/rough start up made me think it was time for injectors. I could be very wrong
 

·
Registered
Joined
·
2 Posts
Also over last couple years all 8 injectors were replaced along with blue spring kit. The accordion style upflow pipes keep breaking allowing exhaust into cap. Not sure why that happens all the time. Diesel shop insyalled 2 on there. Put about $8,000 into truck over last couple years and still having these issues . Should have just bullet proofed it
 
1 - 6 of 6 Posts
Top