Ford Powerstroke Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
118 Posts
Discussion Starter #1
IS IT POSSIBLE THAT MY IDM IS BAD? Truck will not start cold and when it finally does, it idles all lopey and rpm will not go up and harder i push pedal the more white/blueish smoke that comes out tail pipe....allready rulled out glow plugs...
truck never had a problem starting or running but i washed the trucks engine compartment one day and now its acting like this i checked all connections ran for codes did self test on it and came up with nothing

and when it warms up it runs better but still blowing lots of smoke, maybe from sitting idle in the drive trying to get it to run out unburnt fuel
good fuel pressure new filter elements fresh oilchange ebpv functioning properly


motor is stock nomods any body help getting desperate for use of my truck again:nod:
 

·
Premium Member
Joined
·
8,298 Posts
IS IT POSSIBLE THAT MY IDM IS BAD? Truck will not start cold and when it finally does, it idles all lopey and rpm will not go up and harder i push pedal the more white/blueish smoke that comes out tail pipe....allready rulled out glow plugs...
truck never had a problem starting or running but i washed the trucks engine compartment one day and now its acting like this i checked all connections ran for codes did self test on it and came up with nothing

and when it warms up it runs better but still blowing lots of smoke, maybe from sitting idle in the drive trying to get it to run out unburnt fuel
good fuel pressure new filter elements fresh oilchange ebpv functioning properly


motor is stock nomods any body help getting desperate for use of my truck again:nod:
if idm gets wet it may do this. take out idm, shake around, listen for water sloshing around... read that in the 7.3 tech forums.
 

·
Registered
Joined
·
118 Posts
Discussion Starter #3
:dunno:
I checked all connections when i push on throttle pedal rpms will not build up it literally takes it about 2 1/2 minutes to get it above 2000 rpms and is real slugish while doing so doesnt have any leaks of any kind hpop is full new oil in it good oil pressure no codes:doh::dunno:

help somebody:thumb:
 

·
Registered
Joined
·
118 Posts
Discussion Starter #4
so i took the idm out and when I sloshed it around it sounded like it was full of water

i took the siliconed cap off it and to my surprise it was fully covered in water the whole assy was full

i drained all the water out of it and dried it off and waited for an hour and plugged it back in and now it fried it:doh::confused:

i ran the codes on it and it comes back idm fault and icp fault
i ran injector buzz test and it shows injectors check out ok
can only half the idm be bad?:dunno:
does any one on here have an idm for sale:)
 
1 - 4 of 4 Posts
Top