Ford Powerstroke Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
I have done some searching and reading about this very same problem but still dont know whats going on. I have a 96 powerstroke and it started to get the bad idle and loss of power. I unpluged the each harness on the valve covers. When i did the ones on the passengers side the truck almost died out but then idled back up to a rough idle. When ever i do either one on the drivers side there is no change. I went ahead and replace the UVCH and glow plugs and it still does it. If i unplug the ICP there is not change in the idle. There is no check engine light coming on either. Anybody have any ideas.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #2
Replaced the CPS , checked the fuses, and cleaned both the screens on the FPR last night. Still running bad, anybody got any ideas?
 

·
Registered
Joined
·
28 Posts
Discussion Starter #5
You did the UVCH but did you do the valve cover gasket too?
I changed the VC gasket when i did the harness. Nothing in the harness look burnt. When i unplug the harnesses at the valve covers when it is running, the passenger nearly dies out when i do either front or back. When i do either one on the drivers side there is no change.

I did the buzz test last night and only the passenger side injectors would buzz. after running the test it came up with 11 codes.
P1271 - HI to Low side open cyl #1
P1272 - " " #2
P1273 - " " #3
P1277 - " " #7
P1274 - " " #4
P1275 - " " #5
P1276 - " " #6
P1298 - IDM failure
P1294 - HI side open bnk
P0282 - Lowside short cyl 8
p1219 - CID struck low


I think this is all from a bad IDM so im going to try to find one off another truck to make sure that is it.

I there anything else that could be making it do this? :dunno:
 

·
Premium Member
Joined
·
1,975 Posts
Yep, sound like an IDM issue. I'd try one first, then re-run your buzz test. If it's still failing then you need to check wiring. I'm betting IDM though.
 
1 - 7 of 7 Posts
Top