Ford Powerstroke Diesel Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
735 Posts
Discussion Starter · #1 ·
I was at train tracks and my overdrive light came on after a little brake torquing and I stopped immediatly, and when the train passed, while in drive i rolled back before accelerating like a manual. I live near there so i went home shut it off and turned it back on light turned out seemed to drive normal. Any ideas?
 

·
Registered
Joined
·
735 Posts
Discussion Starter · #2 ·
Anyone? Im driving 6 hours next weekend, and I don't want to break down during or before the trip
 

·
Registered
Joined
·
3,381 Posts
If I remember right, when the input speed sensor and output speed sensor get out of a "normal" range it will cause the o/d light to flash. I believe your trans was slipping even though you weren't moving. How does the trans fluid look/smell?
 

·
Registered
Joined
·
735 Posts
Discussion Starter · #4 ·
I didn't smell it yet, but the fluid looks perfect red. And I have been driving for a few days without any problems.
 

·
Registered
Joined
·
735 Posts
Discussion Starter · #5 ·
Well I was expierencing problems again last friday and pulled over and shut it off, to turn it back on. The lights on the dash came on, I waited for the wait to start light to go out, then once I turned the key, it clicked, and everything died. Turned out it was a loose connection from the battery to the inner fender ground. I fixed that and that has been the last of the overdrive light problems. So I am assuming all of the transmission problems was from the ground, not giving good power to a computer for the transmission, causing all of that BS.
 

·
Registered
Joined
·
735 Posts
Discussion Starter · #6 ·
update on the trans, CHECK THE GROUND!!! Ever since I tightened it back up, its fine haven't had a single issue!
 

·
Registered
Joined
·
571 Posts
Still working fine?
 

·
Registered
Joined
·
735 Posts
Discussion Starter · #8 ·
Yeah, I actually ended up replacing the whole ground strap with an integrated ground wire that goes to the fender (the oem one). Ever since had no problems!
 

·
Registered
Joined
·
571 Posts
Can you post a pic of the ground that you fixed thx
 
1 - 9 of 9 Posts
Top