Ford Powerstroke Diesel Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter · #1 ·
I replaced Injectors 4 & 8 after having them Diagnosed at a Ford dealership. This was my 3rd trip into this area (2nd on the right bank) as I have been replacing them as they go out. What I found odd was that one of the ones reading weak was one I had recently replaced. When I removed it, it was still like new more or less looking like I had done the job yesterday. I went ahead with the change out. Once done, when it started up ran on 7 cylinders. I shut it off, checked the plugs and fired it back up. Only 7 were kicking so shut it down. I checked the ScanGauge-X and it showed P0283 DTC meaning #8 High Current current. That says a short in the harness or a faulty solenoid in the injector. I went over the wiring real well seeing no chaffing. I pulled the FICM looking for bent pins with all good connections.
I will do a voltage check on the FICM in the morning, but I highly doubt thats the issue here.
Could the Injector itself be bad? Could there be another issue Im not getting. Is it a viable test to plug in one of the core injectors outside of the motor to see if I get a different reading?
I just dont see how I suddenly have a harness issue.
I have not run the truck other than twice to hear the miss. Maybe a minute total.:shrug::doh::liar::shrug:
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #4 ·
No, I am not going to replace a harness for the simple fact that maybe that's it. I find that little more than a witch hunt hoping for good results.
The reman injector was bad as 3 of 7 of them have now been from performance diesel. This last one was a deal breaker for sure. Had it been "factory bench tested" before shipping they would have noticed the new solenoid had a dead short.
 
1 - 7 of 7 Posts
Top